Global Mapper Pro

selection

williedoer
williedoer Global Mapper User

Many times when re-classifying portions of a point cloud global mapper fails to re-classify the points. Is this a known bug? Is there an option to re-select previous selections anywhere?


Thanks

Answers

  • williedoer
    williedoer Global Mapper User

    this is while selecting in the 3d window.

  • bmg_mike
    bmg_mike Global Mapper Guru Moderator, Trusted User

    Which version of Global Mapper are you using?

    Note that when selecting Lidar in the 3D view, you may be seeing a thinned version of the data in some areas (depending on distance from the camera). If you select an area that is thinned and change the classification, it will just be for those points that were displayed. Anything that was thinned and not displayed isn't changed.

    The 2D view selection behaves differently. If you draw a selection box, everything in that box will be selected, even if some of them were thinned away for display speed.

  • williedoer
    williedoer Global Mapper User

    it is 23.0. I will select a portion of the point cloud - it will appear selected. I will then choose the new classification and once I hit enter it will de-select it but instead of showing the new classification it still shows up as the old classification. its not a "thinned version" of the dataset because it doesn't show anything as changed.

  • bmg_mike
    bmg_mike Global Mapper Guru Moderator, Trusted User

    Do you have the 'Color Lidar by Classification' draw mode selected on the Lidar toolbar? I just tried this in v23.0 (original release) and the 23.1 beta and couldn't reproduce the issue.

    Also, what method are you using to change the classification of the points? I selected them in the 3D view, then pressed the main toolbar button to change the classification. I also tried right-clicking and choosing the Edit option and that worked as well.

    I would also suggest getting the latest 23.0.x daily build from https://www.bluemarblegeo.com/products/global-mapper-daily-builds.php just in case you have some version which has a bug which has already been fixed in what I have installed.

  • williedoer
    williedoer Global Mapper User

    Yes I do usually have it in "color lidar by classification" draw mode. I usually right click in the 3d window and hit edit or sometimes the 2d window. It does work 75% of the time. It's just the 25% that doesn't that is irritating! especially if it took awhile to select the points because it was in a congested area that required rotating and zoom to acquire the different points.

    I downloaded the jan19 daily build but it did not fix the issue.

  • williedoer
    williedoer Global Mapper User

    actually alot of the times I am using the buttons on the "lidar (manual classification)" toolbar instead of right clicking and then editting.

  • bmg_mike
    bmg_mike Global Mapper Guru Moderator, Trusted User

    So far I'm unable to reproduce this even with a lot of select and edits. I've created todo item GM-13218 to track this.

    My first thought is that somehow the selection is being cleared before the classification change is received.

    Have you tried reclassifying the points via the path profile tool? I often find it's much easier to find the Lidar points I want to grab in that view rather than trying to manipulate the 3D view where it's way to easy to grab a swatch of stuff down the sight-line of a selection box.

  • williedoer
    williedoer Global Mapper User

    I am starting to think it was a file size issue. I have removed a large dtm I had created and another large portion of the point cloud I no longer needed and the issue does not appear to be happening. I was also have the software lock up on me quite often and now that I have reduced the workspace size to < 0.6 gb it appears to have solved that issue as well.


    Thanks for your help!!

Sign In or Register to comment.