Incorrect feature name encoding

tikhpetrtikhpetr Posts: 51
Hi!
I have a layer of polylines (rivers). Their names should be displayed in Russian. The .cpg and .dbf files are UTF-8 encoded. In the attribute table, the corresponding columns are displayed correctly. When I try to search by attribute, I get an incorrect result.
I tried to change encodings in files and display labels, result = 0.
Please help to solve this problem.        https://yadi.sk/d/AS30g2kS1ulnTw ; - file link

Best Answer

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,161
    edited July 6 Answer ✓
    Hello,

    This appears to be in instance of a bug that was fixed after the release of Global Mapper 21.1. Please download the latest daily build here to see if that resolves your problem. If it does not, please contact Blue Marble Support directly via email for further investigation. Please include a detailed description of your workflow and the data set that can be used to reproduce the problem. Thank you.

    Cheers,
    Bob

Answers

  • tikhpetrtikhpetr Posts: 51
    Hello, Bob!
    Today at midnight I solved this problem. I re-exported the original shp file with export options, as in the image.
    Thanks!
  • sphillipssphillips Posts: 193
    tikhpetr said:
    Hello, Bob!
    Today at midnight I solved this problem. I re-exported the original shp file with export options, as in the image.
    Thanks!
    I notice that some of your Russian names still have ?????????????? in them even after your workaround.

    I understand your frustration. I work with Russian datasets all the time but cannot use Global Mapper for any of it. No issues opening Russian data with other GIS programs. I've been asking Blue Marble support for Russian/Cyrillic data to be supported for years but no luck yet. 
Sign In or Register to comment.