"Export Raster/Image format" yields wrong result with "Crop to Selected Area" + "Save scale..."

SetiSeti Posts: 6
Hi there,

A weird behaviour whe I am trying to export to a raster image format, I have tried with PNG and GeoTIFF.
I have been trying to export the red area below within the yellow polygon. I have selected the "Crop to Selected Area/Feature(s)" option. I have never had issues with this option before. I used it often recently. I am doing this:


Then, in the PNG Export Options tab, I am selecting the options as on the screenshot below (which are default; pixel size is equivalent to 15 meters, which is the true image pixel size and what I am looking for). Then, ok. The resulting file is the small black and white box on the screenshot in the lower right:

Which I am also pasting here:

It looks like a fragment of a scale in km. But note that the scale of the exported image is expected to be in meters. It could be from an earlier scale while working with a different zoom. But the three black lines of the frame do not correspond to anything expected in the scale bar either, and the letters "km" are doubled.
The image is Landsat-7, and projection Lat-Lon with WGS84. There is no other layer activated in the Control Center window.

However, when I uncheck the box "Save Scale/Elevation...." in the PNG Export Options tab, the file is correctly exported:

In summary, there is something not normal happening when the export area is to follow a cropped area and include the scale/legend.


Best Answer

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,146
    Answer ✓
    Hello,

    I ran a test using your export options in Global Mapper 21.1 (b061420) and both GeoTIFF and PNG produced the correct output. I suspect that you have run into a bug in Global Mapper 19 that has since been fixed.

    Cheers,
    Bob

Answers

  • tikhpetrtikhpetr Posts: 46
    Hi, Seti!
    On the first screenshot you have selected not a polygon, but a polyline.
    ASTER GDEM i exported successfully. Check: configuration - export.
    I have so:
  • SetiSeti Posts: 6
    Hi tikhpetr;
    I am not sure I understand how your screenshots are related to the issue I raised, but the feature I have selected is a of course a polygone, not a polyline. A polygone created using the Create rectangle/square area feature tool.

    And as I wrote above, the problem arises when the scale is displayed, otherwise exporting works fine. Does anyone have an idea?
  • SetiSeti Posts: 6
    Ok Bob, I will check in the next version I purchase, hopefully soon! Thanks

Sign In or Register to comment.