unable to import Japan DEM data from an archive

Hi, 

I am trying to load Japan DEM data from a zip file and I am getting the following error:

Reading of this data directly from an archive is not supported. Please unarchive the data and try again. 

I was able to import the same data just a couple of weeks ago on a different machine.  For some reason, now I am not able to import the data. 

Any ideas?

Thanks.

Stephen 

Best Answer

  • MicheleMichele Posts: 47
    Answer ✓
    Hello,
    We also get that error when importing Japanese data on a machine which locale is set to Japanese.
    Change your administrative locale settings to English and it will work. To do this go to control panel > clock and region > region. There you have a tab called "administrative". Go there and change it to English.
    Best regards
    Michele
    sirish19Mykle

Answers

  • MykleMykle Global Mapper User Posts: 451Trusted User
    Are you able to unzip the contents, whether into your current folder or a subdirectory?  If the zip file has only one or two files, the current folder will work well.  If there is a collection of files and/or folders, then extracting the contents into a subdirectory will work better.  Then use the Open dialog in GM to display the files and select the data file of interest (the reason for using the Open dialog is to display the most relevant files and not the support files, hopefully making your selection less complicated).  The contents of a zip file can be complex, so GM needs help from you. 
  • sirish19sirish19 Posts: 3
    Hi, Thanks for your reply. So what I have is a zip file containing data of an area that was downloaded from this site https://fgd.gsi.go.jp/download/mapGis.php?tab=dem.  A few weeks ago, I was able to just drop this zip file into GM and it would ask me to select the overlay type.  I chose Japanese GML DEM.  Then it would give me an "unknown projection' error so I would select "Geographic" and check the box that says "Use selected projection for all selected files". 

    However, now, when I try to open that zip file, I get the error above.  If I extract that file that contains compressed zip files of each grid mesh that I downloaded.  One example of those files is attached here.  If I try to import that zip file, I still get the same error.  If I then extract that file, then I end up with many compressed XML files.  I cannot open the compressed XML files in GM so I need to extract them in order to import to GM which I can do.

    The problem is, I am going to end up with thousands of files and even if I extract them all and try to import them even in bulk, I end up being required to select overlay type and then select projection for every single file.  This is just not feasible. 

    I am really stuck as to why I was able to do this with no problem a few weeks ago but am now unable to do it. The only thing that has changed is that I have upgraded my machine and have added a new license to the software.  

    I am also attaching the bug log here in case anyone could help me figure this out. 
  • MykleMykle Global Mapper User Posts: 451Trusted User
    Hi Stephen,
    Thanks for sharing one of the zip files. 

    I am suspicious that the format may have changed since your previous download.  Do you still have that data, and is it structured the same?

    The XML files look like they contain data that can be elevation values, and location values are included.  I am not used to working with files of this type, so can't say anything about GM's ability (or not) to load the data. 

    I am also suspicious of Japanese characters that are included in the XML files.  They are used in description, name, QuantityList, and type parameters, as well as a descriptor for each data value.  Some of these parameters may accept Japanese characters (and any other high-level character sets), and some may not.  We could assume that these files have been tested and work, but maybe not. 

    Another uncommon issue may be applicable in pathnames that include space characters, like at the top of the file where the schemaLocation value is a pathname that includes a space.  The pathname is enclosed in quotes, so I may be off-base with this thought.  Still, that space is suspicious. 

    The most important detail may result from your comparing the format of this data with a previous dataset that you were able to load. 

    Otherwise we will have to defer to the gurus.

  • sirish19sirish19 Posts: 3
    Michele said:
    Hello,
    We also get that error when importing Japanese data on a machine which locale is set to Japanese.
    Change your administrative locale settings to English and it will work. To do this go to control panel > clock and region > region. There you have a tab called "administrative". Go there and change it to English.
    Best regards
    Michele
    Hi Michele,

    Thank you so much for your insight, sure enough, that was it!!  I had previously run these files on a MBP running windows on bootcamp but recently bought a new computer here in Japan where the regional settings were for Japan.  As soon as I changed the settings, I could import the files with no problem. 

    Thank you so much for your help.

    Sincerely,

    Stephen

Sign In or Register to comment.