NTF processing (calculate autocontrast)

EarlEarl Global Mapper UserPosts: 8
edited July 2008 in Raster Data
I have some quickbird imagery in NITF format, which I can't open with Global Mapper. The file is about 470MB, and seems to hang for a very long time. It's possibly working correctly and just needs time, but is there a way to skip autocalculation and let me specify the stretch I want, to save time?

This is just the 470MB multispectral NITF raster, I'm afraid to try the 1.6GB panchromatic.

Similar subject, for raster files which have collars of null data (or a set RGB value like 0,0,0) is there an option to set a preference in Global Mapper so this doesn't have to be edited per file? I had trouble trying to merge a few sat images into one larger image because of this.

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited April 2008
    What version of Global Mapper are you using? Some newer version of Global Mapper handle additional NITF versions a little better and also allow setting the transparent color for multiple layers at a time. If you are on the v9 series of releases, I would suggest downloading the latest build from http://www.globalmapper.com/global_mapper9.zip and extracting the contents over your existing v9.xx installation to see if that helps.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • EarlEarl Global Mapper User Posts: 8
    edited July 2008
    I am now using v9.03 (April 30th build date). I have some related questions about handing Quickbird data -- maybe the issue is more about 16-bit four-channel images rather than the specific format it is stored in.

    By way of example, thought it is low resolution and geotiff format:

    ftp://sidads.colorado.edu/pub/DATASETS/ARCSS/data/arcss305/QB_Full_Extent_Mosaic/qb10_multi_p002_16bit.tif

    When I open this in GM, I can change the first and third channel around so that I see a correct representation of RGB, but I am unable to hide the collar, and I think this is interfering with autostatistics. I'm unable to access the statistics in a way that I feel would let me get a good representation. Am I doing anything wrong?

    In adobe photoshop I can edit histogram of each channel and have a good looking image in about 20 seconds. You don't have to explain the difference between resources of Adobe and Global Mapper Software, I also work in a very small development team, I just wonder if it is difficult to skip autocontast and give the user more direct control of each channel, in order to apply a consistent scheme to a set of images from the same pass, and save a lot of time.
  • timhomantimhoman Global Mapper User Posts: 49Trusted User
    edited July 2008
    Try this...
    Load the image in GM.
    Open the GM control center (Tools->Contorl Center...) - the Overlay Control Center panel will open.
    Highlight the loaded image within the Control Center listing.
    Select "Options" - the Raster Options panel will open.
    Select the "Display" tab.
    Go to the "Transparency" group and -check- "Transparent".
    Select "Set Tranparent Color" and select a color that represents the collar.
    Select "OK" (from within the Color panel).
    Select "Apply" or "OK" (from within in the Raster Options panel).
    Hope this helps.
    btw - I had to switch bands 1 & 3 in the sample image you provided.
    --
    Tim
  • EarlEarl Global Mapper User Posts: 8
    edited July 2008
    I tried and couldn't remove the collar -- were you able to? I even took a screenshot and brought the image into Photoshop to get the exact RGB of the collar, which wasn't quite black, but even with "make similar colors transparent" it wasn't working. I assume the input should be the 8-bit color of the collar after autocontrast.
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited July 2008
    When specifying a transparent color you need to specify the color BEFORE the contrast is applied. In this case if you choose exactly black (RGB 0,0,0) as the transparent color you should get the results you are after (it worked well for me).

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.