Jagged overlapping contour lines instead of smooth natural curves

I am absolutely a newbie to Global Mapper. I am using version 20.0.0. on Windows 10 - 64 bit. I used SRTM Worldwide Elevation Data (1-arc-second Resolution, SRTM Plus V3) to generate contours out of a kmz file which is of location in Haryana, India. 

The contour interval that I took was 0.5 metres. Some contour lines are coming out not to be smooth but unnatural, polygonal jagged. 

Another trouble I am facing is that contour lines are overlapping, (as highlighted with with white doodles in the screenshot). In the contour generation options, I used 0.00 i.e. less simplificatipn. 

What should I do to generate accurate contours?

Here is the kmz file used for site boundary. 




 


Tagged:

Best Answer

  • sphillipssphillips Posts: 142
    Answer ✓
    You can smooth the contours after they have been generated.

    1. Select them with the Digitizer Tool
    2. Right-click > Move/Reshape Feature(s) > Resample/Split Selected Features(s) at Specified Spacing
    3. Choose Sample Features at Fixed Distance Interval
    4. Enter the Spacing Distance e.g. 5 or 10 meters
    5. With the contours still selected Right-click > Move/Reshape Feature(s) > Smooth
    There are lots of ways of exporting the 3D terrain. Can you let us know what you intend to use the terrain for so we can best advise you?

    By the way if you want to clip the SRTM to your boundary you can select the boundary be fore you select the online data source and choose the option at the bottom to Download Within the Currently Selected Polygon(s).
    archz2

Answers

  • sphillipssphillips Posts: 142
    I think your problem may lie in your simplification settings. Try reducing the simplification via the Simplification tab.
    archz2
  • MykleMykle Global Mapper User Posts: 447Trusted User
    Note that the resolution of SRTM data is relatively coarse.  In the north-south direction, one degree (of latitude) is about 111,120m, and your resolution (Y-axis) is about 0.0003433 per degree, so one pixel is about 38m.  Drawing contours at an interval of 0.5m may not provide the results that you would like.  It depends upon the topography, with flatter terrain being easier to contour at a small contour interval.  More interesting terrain may wind up with contours that are more jagged and/or overlapping.  If you select smooth contours, that may increase overlapping.  Drainages may show low sections that don't "flow" smoothly.  All of these settings work together and can conflict, like in your results: large pixels, small contour interval, with smoothing. 

    As sphillips suggests, adjusting simplification may help.  A larger contour interval may help.  You get to play with the settings to find the values that work best for you.  (data with greater resolution will help the most, but we certainly understand when better data are not available).

    archz2
  • archz2archz2 Posts: 5
    I had set the simplification to zero, when I posted here for the first time. I forgot to take the screenshot. 

    Okay, now I changed the contour interval to 1m, the number of overlapping contours lessened. Of course after changing the interval to 2 metres, I get no conflicts as the contours which were showing up for 1m interval and overlapping, they just disappear. Eventually, the problem gets hidden, but it still exists. 

    Anyway, I can get contours for 0.5 metre interval and not get overlappings?





  • 946946 Global Mapper User Posts: 140Trusted User
    Yes,
    Just export your raster to 0.5m and create the contours again. 
  • sphillipssphillips Posts: 142
    If you uncheck Smooth Contour Lines/Areas to Improve Appearance the contours will not overlap. I have just loaded up the SRTM V3 for your geographic location and generated 0.5m contours without any overlaps. If I check the smoothing option on I get overlaps.
  • archz2archz2 Posts: 5
    sphillips said:
    If you uncheck Smooth Contour Lines/Areas to Improve Appearance the contours will not overlap. I have just loaded up the SRTM V3 for your geographic location and generated 0.5m contours without any overlaps. If I check the smoothing option on I get overlaps.

    Thanks. That removes the overlap. But now the contours look unnatrual, very polygonal. 

    I guess, I will have to generate contours separately in another software from the terrain file.

    Any method by which I can export the 3d terrain along with the kmz overlap? I tried exporting the fbx file, but it only export the terrain as a mesh without the boundary set by the kmz file. 
  • archz2archz2 Posts: 5
    Thanks a lot for replying. I intend to do slope percentage analysis like this in Rhino and Grasshopper. Though I haven't found  a neat way to do which generates colour coding like this. 


  • sphillipssphillips Posts: 142
    You could do something similar in Global Mapper with a custom slope shader using the equivalent degrees.


    archz2
  • archz2archz2 Posts: 5
    sphillips said:
    You could do something similar in Global Mapper with a custom slope shader using the equivalent degrees.



    Ohh!! Interesting!.. Well, actually I would also like to have polygons generated too based upon the colour coding. Can I also do that?

    Like separate polygons generated for all slopes more than 25%, 20%, etc. 
  • sphillipssphillips Posts: 142
    archz2 said:
    sphillips said:
    You could do something similar in Global Mapper with a custom slope shader using the equivalent degrees.



    Ohh!! Interesting!.. Well, actually I would also like to have polygons generated too based upon the colour coding. Can I also do that?

    Like separate polygons generated for all slopes more than 25%, 20%, etc. 
    1. Export out the layer as a PNG making sure the hill shade is off first
    2. Import the image
    3. Right-click the layer > Layer > Create Area Feature(s) from Equal Areas
    4. Use defaults
    5. OK
Sign In or Register to comment.