I have a very simple script that works in v15, but fails in v20

ScrvdogScrvdog Global Mapper UserPosts: 4

I copied some code from the Global Mapper Scripting Reference v20.1, the code works fine in v15, but does not work in v20.1

Here is the code I am testing:

GLOBAL_MAPPER_SCRIPT VERSION=1.00
DEFINE_VAR NAME="DATA_DIR" PROMPT=DIR
IMPORT FILENAME="%DATA_DIR%\Office2.shp"

I get the following popup error message "The file %DATA_DIR%\Office2.shp could not be found at the location specified. Please select the new location of the file or press Cancel to skip loading this file."

The is the error in the scripting window:

ERROR: The required METADATA_LAYER parameter is missing for the DEFINE_VAR command. ERROR: File %DATA_DIR%\Office2.shp does not exist. Script processing CANCELLED.

Is there something that has changed in v20 to prevent this for working?

Thanks,

Gary

Best Answer

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,002
    Answer ✓
    Hello Gary,

    That is a bug that is fixed in the latest release of Global Mapper 20.1. Please download the latest version from our download page. If you still have the problem after installing the latest release of Global Mapper 20.1, please contact Blue Marble Support directly via email (geohelp@bluemarblegeo.com). 

    Cheers,
    Bob

Answers

  • ScrvdogScrvdog Global Mapper User Posts: 4
    Thanks Bob, appreciate it.
Sign In or Register to comment.