Global Mapper Pro

Mosaicing

miksmith
miksmith Global Mapper UserTrusted User
edited August 2008 in Technical Support
When you do an export, does GM export all the visible layers as one, in essence mosaicing them? This appears to be what happens, however in areas of overlap, how is the final output value determined <min, max, mean etc)?

thanks

mike

Comments

  • global_mapper
    global_mapper Administrator
    edited April 2008
    Mike,

    Yes, an export combines all loaded data as one. The topmost layer with valid data at a given location will be used. You can re-order layers by right clicking on them in the Control Center and selecting the option to move them around in the draw order.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • kbotnen
    kbotnen Global Mapper User
    edited July 2008
    Is there any possibility to export as layered file at all? The mosaic can then be refined in i.e Photoshop or another software that handle layered files. Or is there any other way to get more artistic control over the layers appearance?

    Ofcourse there is the option of exporting one layer at a time within same bounds, and assembling them by hand in PS, but can this be automated in some way?

    -K-
  • global_mapper
    global_mapper Administrator
    edited July 2008
    There is not any built-in support for a layered file format like Photoshop would use. You could use the File->Batch Convert menu command to easily create a separate file for each of the files that you have loaded.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • kbotnen
    kbotnen Global Mapper User
    edited July 2008
    That did almost work. The only thing I miss now is a way to set the export bounds. I want to export the whole area (that is the image that the whole mosaic cover) not just the area that each tile/image/layer in the stack covers. Is this doable? Again It is managable when doing it manually, so I guess it can be automated somehow too :)

    -K-
  • global_mapper
    global_mapper Administrator
    edited July 2008
    What you could do for that is to first draw an area feature in the main map for what you want everything to cover, then select that area with the Digitizer or Feature Info tool. Then when you do your batch conversion, check the option box to crop the export to the selected area feature. This should generate all of the output tiles covering the same area.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • kbotnen
    kbotnen Global Mapper User
    edited July 2008
    Hmm. The idea sounds quite right, but it does not work as expected. All the individual images does come out cropped to their own sizes/area, not the entire area that I have selected (created as described in your last post). The result should have been many huge files with the layers being the smalles part of each exported image. And a lot of yellow. When creating an Imagestack in PS it would have been assembled again, setting the yellow color as transparent.

    Your trick does crop innward though, but I need the exporter to expand out to the area feature that I created. A kind of fill to -area feature bounds- option.

    But I have to honor the ery fast and relevant help in this forum, thank you :)

    -K-
  • global_mapper
    global_mapper Administrator
    edited July 2008
    You are correct, it does appear that when cropping to an area that each layer is still just exported to its bounds and the results cropped, but the bounds of the crop area are not used. I will add some sort of option to control this behavior and get back to you.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • global_mapper
    global_mapper Administrator
    edited July 2008
    I have updated the batch conversion process in Global Mapper so that when you crop to selected area features during batch conversion you will now also be prompted to specify whether to make the exported results use the bounds of the input file or of the selected area features.

    We are in v10 development so this is available in a new v10 build if you are using v10 beta 1 (see the Announcement forum thread about this from yesterday). I have placed a new build at http://www.globalmapper.com/global_mapper10.zip with the change for you to try. Simply download that file and extract the contents into your existing v10.xx installation folder to give it a try.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • kbotnen
    kbotnen Global Mapper User
    edited August 2008
    Hi.

    This was not as easy as I thought. I tried the new 10 beta. I got the dialog box which give me cropping options, but it does not work as expected. After some thoughts I think the problem is due to sample spacing. It have to use the same sample spacing on all exported images to avoid cropping. So here is the manuel steps that will make layer export suitable for PS imort.

    1: Export overview of your area, now we have the export bounds on "last used export bound"
    2: Turn off overview layer, on first detail layer. Export with "last used bounds" and the same sample spacing used in 1.
    3: Turn off first detail layer, turn on second detail layer. Export with "last used bound" and the same sample spacing used in 1 and 2.
    4: Repeat point above until finished.

    This will give you raster images with same width and height, which is ideal to load into the "load into image stack" script in PS. But ofcourse, with many many layers the export is a very time consuming work which I still believe can be automated fairly easy in some way or other :)

    I have attached a screenshot to illustrate the above story. Each of the layers are 2815x3757 in size, exorted with 0.5 sample spacing and transparency is due to using .png file format.

    layer_export.jpg

    -K-
  • global_mapper
    global_mapper Administrator
    edited August 2008
    K,

    You should be able to use the Sample Spacing settings during batch conversion along with the new crop to area option to keep the entire bounds to get the same results as you describe in a more automated fashion.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • kbotnen
    kbotnen Global Mapper User
    edited August 2008
    It worked. There was an 'Do not resize final image' option on the batch option pane.

    But here for my next question. I downloaded the new Beta2 version and installed it (I bought it to override the max 3 batched images restriction in the demo) and guess what. The batch conversion function are now no longer present? Is this a mistake or have it be decided to let it out from the 10 version? Or maybe its moved somewhere else that I havent figured out yet?

    Never mind. I figured out. So now I am happy :) The option did not showed before a legal area feature was selected. Context sensitive in other words :)

    Thanks.

    -K-
Sign In or Register to comment.