How to specify projection for export of shapefile?

Shape file .prj file after export have no "PROJCS" specified. 

As far exported prj file is following:  
GEOGCS["GCS_WGS_1984",DATUM["D_WGS84",SPHEROID["WGS84",6378137,298.257223563]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]]

No matter, if I'll change projection (from Geographical to OSGB) of the layer in the project, result is always the same.

In attachment there is the file that have "PROJCS" in the projection file, I wish to get the same with GM. 

This is .prj content from attachment: 
PROJCS["OSGB_1936_British_National_Grid",GEOGCS["GCS_OSGB 1936",DATUM["D_OSGB_1936",SPHEROID["Airy_1830",6377563.396,299.3249646]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]],PROJECTION["Transverse_Mercator"],PARAMETER["latitude_of_origin",49],PARAMETER["central_meridian",-2],PARAMETER["scale_factor",0.9996012717],PARAMETER["false_easting",400000],PARAMETER["false_northing",-100000],UNIT["Meter",1]]
As the input I'm using DWG file.

Answers

  • linnylinny Posts: 3
    I'm very amatuer , but do you need the prj file? The times I've exported shapefiles I get better results not using the prj file
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,896
    Hello,

    After you load your shapefile, change the projection to OSGB using the Configuration dialog (Projection tab), not the layer options dialog.  Afterwards, when you export the shapefile, be sure to check the option to write a PRJ file also.

    Cheers,
    Bob
Sign In or Register to comment.