3D view not starting in ver. 20

Hello,
As the title says, since we upgraded to ver 20, some files refuse to start the 3D view.
Attached here is a very simple gmp file that, no matter how we open it with ver 20, refuses to open 3D view.
Same file, if opened with ver 19, still refuses 3D view but with ver 18.2 works normally.
We are using the ver 20 from daily builds of 20th november 2018.

Comments

  • henniehennie Global Mapper User Posts: 53Trusted User
    I created a terrain grid with your contours. When loading this together with your contour lines, it opens perfectly in GM20. See attached grid file.
  • BillBBillB Global Mapper User Posts: 113Trusted User
    Hi, it may be worth checking that it is not just a case of the 3D window being lost "off-screen".  This can happen especially if you have multiple monitors, or one plugged in occasionally (eg to a laptop) then removed.  See

  • MicheleMichele Posts: 42
    @BillB I tried that and it is not there, the 3D button in GM is not even colored after pressing it. It just seems like it's not doing anything.

    @hennie I don't know why it would work after creating the grid but, did it work for you without grid? It should start anyway and display whatever is on screen like in the old versions, right?
  • henniehennie Global Mapper User Posts: 53Trusted User
    Just now tried it with GM 20.0.1 (b112018)(133) an it works without having to create grid. See pic attached.
  • JeffH@BMGJeffH@BMG Global Mapper Developer Posts: 305Trusted User
    Hi Michele,

    It would be pretty unusual for the 3D viewer to not open at all. I downloaded your test file and it works fine for the very latest 64-bit version of Global Mapper, without needing to create a grid. 

    Just a couple of questions:
    * Are you using the 64 or 32 bit version 
    * Does the 3D view open at all for other data sets, or with no data at all? If it opens with no data, what hapenes if you open it with no data, then load your test file?

    Best regards,

    ~Jeff
  • MicheleMichele Posts: 42
    @JeffH@BMG ;
    Hi, I just tested with both today build and the official build. 3D doesn't show up even with completely empty workspace in a newly opened instance of GM. We use 64bit version.
    Best regards
  • MicheleMichele Posts: 42
    We solved this! We had to erase registry entries from GM and reinstall from scratch and then the 3D view works again. Though, if I open the file from which the attachment was extracted, the same thing happens again and from that moment all other files don't show 3D anymore. I can only guess that file saved some strange default setting that compromise the behavior for GM. 
    Thanks to everyone for any help you gave us.
    Best regards
  • BillBBillB Global Mapper User Posts: 113Trusted User
    Michelle - glad you were able to resolve this and thanks for sharing the fix :)
  • JeffH@BMGJeffH@BMG Global Mapper Developer Posts: 305Trusted User
    Michele said:
    We solved this! We had to erase registry entries from GM and reinstall from scratch and then the 3D view works again. Though, if I open the file from which the attachment was extracted, the same thing happens again and from that moment all other files don't show 3D anymore. I can only guess that file saved some strange default setting that compromise the behavior for GM. 
    Thanks to everyone for any help you gave us.
    Best regards
    Hi Michelle,

    Glad you got it solved. I'd be very curious as to which registry entries you needed to delete. I can't think how loading a file would disable 3D. I did load and test the one you posted above and it worked fine. Color me puzzled.

    Best regards,

    ~Jeff
  • MicheleMichele Posts: 42
    Hi,
    The registry keys are the ones under HKEY_CURRENT_USER / SOFTWARE / GLOBAL MAPPER.
    We reached the solution because we noticed that uninstalling GM didn't reset the workspace look so we thought this problem could be related to the workspace default appearance and then we thought of deleting also the registry.
    It was mostly a struck of luck, i guess. Luckily it worked.
    Best regards
Sign In or Register to comment.