Exported DXF boundary doesn't match original source data (ASC)

veddycentveddycent Global Mapper UserPosts: 53
Hi all,

I'm a bit confused by this one.
I have a terrain square (5000m X 5000m, 5m resolution) in ASC format, I export it as a DXF 3D Face, gridded (1024m X 1024m), NO resampleing but the edges don't seem to match the source data.

It looks like the last bit is 4m tall but because the sample spacing is 5m it excludes it. This is a huge problem because it will leave a gap between the hundreds of tiles I have.

Is there anyway to make Global Mapper export this part whilst keeping 1024m gridding and 5m sample spacing?

I have attached an image to help illustrate my point.

GM Version: 19.0.2 (b112717)(1)(64-bit)

Any thoughts are welcome.


Comments

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,971
    Hello,

    The dimensions of the data can not be evenly divided into tiles of the size you have specified (tile size of 1025 m x 1025 m would cover your data exactly). What would you choose to have Global Mapper do with the extra? Create additional tiles cropped to the export data bounds (currently an option if you specify the number of rows and columns)? Something else?

    Cheers,
    Bob
  • veddycentveddycent Global Mapper User Posts: 53
    Hi Bob,

    Thanks for the reply.

    It would make sense to make the last tile be the size of what is left so 4m, that way no data is lost on export.

    The reason why I'm doing the tile as 1024 m x 1024 m is because an aerial image of size 4096 px x 4096 px, 25cm resolution fits perfectly on said tile.

    I have just noticed that a polygon in the top right corner is also missing. This is when the elevation data is exported as one piece. I have attached a file with both files

    Kind Regards,
    V
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,971
    Hello,

    With regard to the missing polygon, I suggest that you update to the latest release of Global Mapper 19 (or if you like, you can get the latest Global Mapper 19 daily build.) If the problem persists, please send an email containing a detailed description of your work flow (including export options used to create the DXF file) and your data to Blue Marble Support (geohelp@bluemarblegeo.com). 

    With regard to the extra data, you will need to check the option "Crop Right and Bottom Cells to Export Bounds". Although it is under the option for selecting rows and columns, it will be applied when you specify the cell width and height.  That window layout may need a little adjustment to make this more obvious.

    Cheers,
    Bob
  • veddycentveddycent Global Mapper User Posts: 53
    Hi Bob,

    Thanks for the info!

    Latest build and Crop Right and Bottom Cells to Export Bounds worked a treat but the nightly didn't.

    The top right and bottom left corners have missing polygons so I will drop an email with sample files.

    I think you're right about the window layout.

    Regards
    V
  • veddycentveddycent Global Mapper User Posts: 53
    EDIT: After exporting again Crop Right and Bottom Cells to Export Bounds doesn't actually solve the issues. I have reported the issue.

    Thanks

  • veddycentveddycent Global Mapper User Posts: 53
    Hey,

    I'm not sure where to follow up with the progress of a reported issue, so I'll ask here in case another user comes across the same issue.

    I contacted your support team and they have issued a Support Ticket (#25285).
    I'm wondering if there is an update to the fix and if this will be applied to V19 which is the version I currently own.

    Also is there a URL where these issue can be tracked?

    Kind Regards
    Ved
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,971
    Hello Ved,

    The most recent update on Support Ticket #25285 says:

    "The issue is that the edge of the last column and row of DXF faces goes outside of the data. Faces with invalid samples are dropped, so you don't get the last row/column.

    "This is caused because the specified cell size (1024m x 1024m) is not an even multiple of the specified spacing of 5m x 5m. In this case, either the bounds or the sample size has to be changed. Which one gets changed is determined by the 'Maintain Export Bounds Instead of Sample Spacing' setting on the Configuration dialog's General->Export tab. If that option is checked prior to export, the 5m sample spacing will end up very slightly smaller (i.e. 4.9951m) but the exact bounds are maintained and no data is missing."

    We don't have a publicly accessible location where support tickets can be tracked.

    Cheers,
    Bob
  • veddycentveddycent Global Mapper User Posts: 53
    Hi Bob,

    Thanks for the reply. I take it this only applies to V20? If so is there any plans to add this fix to V19?

    Thanks
    Ved
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,971
    Hello Ved,

    I don't think any changes were made.  The "Maintain Export Bounds Instead of Sample Spacing" option is on the General | Export tab on the Configuration dialog in Global Mapper 19.

    Cheers,
    Bob
  • veddycentveddycent Global Mapper User Posts: 53
    My apologises if I'm being dumb but I can't see "Maintain Export Bounds Instead of Sample Spacing" in the export menu. I've attached an image with all the menu options.

    Thanks
    V

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,971
    Hello Ved,

    The "Maintain Export Bounds Instead of Sample Spacing" option is on the General | Export tab on the Configuration dialog in Global Mapper 19, since it may apply to any export format, not just DXF.  It is not in the DXF 3D Face Export Options.



    Cheers,
    Bob
  • veddycentveddycent Global Mapper User Posts: 53
    Hi Bob,

    I've been testing out many options to get the exports correct.

    Checking Maintain Export Bounds Instead of Sample Spacing looks like it works but when you zoom to the edge it leaves a small gap of about 4mm. I know this is small but it will cause issues when we use this in out interactive application (camera collision with terrain).

    I tried another approach by creating the desired export tiles as shape files and using Use Selected Area Feature(s) for Tiles (see image below) this very nearly works but drops a column of polygons on the far left only.



    Are there any settings in General | Export tab on the Configuration dialog that can possibly fix this?

    Regards
    V
  • veddycentveddycent Global Mapper User Posts: 53
    To add to my above comment. I found that loading adjacent terrain tiles removes the dropped polygon on the far left edge when using Crop to Selected Area Feature(s) in Export Bounds tab (DXF 3D Face Export Options).

    I have a script which automates the above process but unfortunately using POLYGON_CROP_FILE="%SHAPE_FILE_CROP_URL%" does not take into account the setting "Maintain Export Bounds Instead of Sample Spacing" in General | Export tab on the Configuration dialog in Global Mapper 19 and the exported DXF extends past the POLYGON_CROP_FILE.

    It looks as though these export options all produce different results
    POLYGON_CROP_FILE="%SHAPE_FILE_CROP_URL%"
    Crop to Selected Area Feature(s) in Export Bounds (DXF 3D Face Export Options)
    Use Selected Area Feature(s) for Tiles in Tiling (DXF 3D Face Export Options)

    Would it be possible to get some clarification on this?

    Regards
    Ved
Sign In or Register to comment.