When accessing a data source of a local mapnik server, rows are not displayed in the correct order

I am working with a local mapnik server serving up OSM rendered tiles.   When i try to access it through a new data source in GM19.1, I get the following composite image, and all zoom levels show same behavior.  Appears the middle row is correct, but each of the other rows are on the wrong side of the middle row.   I have attached to the mapnik server with some other tools, and they appear fine.   I do not see any settings within the data source definition dialog that would cause this.   I have tried adding new source types of Google Map Tiles, OSM, and TMS, and they all show the same issue.  

The url I am using is http://[server-ip]/tiles/%z/%x/%y.png, and all other settings are left default

Not sure if problem is with how GM is asking for the data, or the way Mapnik is configured.  Anybody seen this behavior and have a suggestion on where to look for a solution?


Best Answer

  • staffordtstaffordt Posts: 2
    Answer ✓
    Continued to do some searching on the forums.   Saw something about someone trying to use opentopomap before it was added to GM.   Noticed he only used  http://[server-ip]/tiles/ as the URL.. without the zoom, x, and y values.    So I tired it, and it worked.  So consider this solved.

Sign In or Register to comment.