How to Be Rid of Unwanted Display of Scientific Notation?

kbelliskbellis Global Mapper UserPosts: 417Trusted User
Hello,

During beta testing of v19 last September, I originally reported this issue. I thought that it had been addressed. Lately, I've been noticing it again and find it annoying enough to report the issue again. The issue is the unwanted display of numeric values expressed in scientific notation even when the option to do so is otherwise unchecked. Is there an overriding default value the preempts the Vector Options setting?




Answers

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,776
    Hello,

    On the Configuration dialog, under the General | Vector Formats tab, in the Shapefile/DBF section, check the option to "Reformat Numeric Attribute Values Using Scientific Notation".  You may need to import your data again to see the results.

    If I recall correctly, this was happening because the values were stored as strings in scientific notation, and Global Mapper just saved the string values. We added this option to inspect the values and reformat numbers so they are no longer in scientific notation.

    Cheers,
    Bob
  • kbelliskbellis Global Mapper User Posts: 417Trusted User
    Hello Bob,

    Thank you for the reply; however, after implementing the change, and even exited Global Mapper entirely and opening the work space, the issue is still present:




    Reloading the shapefiles isn't exactly possible:


    After much begging and pleading, MEGIS finally provided one monster shapefile for every ortho index in the state, from which I then completed 41 separate queries to isolate the indexes by the attribute ProductName. For me to reload the data and then chop it up all over again seems like a poor solution to a problem that shouldn't have even been present to begin with; i.e., why isn't the Reformat box checked to begin with by default?


  • kbelliskbellis Global Mapper User Posts: 417Trusted User
    The file Todd sent is too large to upload onto the forum (about 11MB). If you want to try it, let me know and I'll upload it to a site of your choice.
  • kbelliskbellis Global Mapper User Posts: 417Trusted User
    And for what it's worth, the check box description isn't exactly clear as it can be interpreted in two ways: "Reformat Numeric Attribute Values Using Scientific Notation"

    The box being unchecked should mean that I don't want to see scientific notation, and that I should check the box if I do want to see scientific notation.

    You suggested that I change it from being unchecked to check, which I did.

    I next began a new workspace and loaded that same shapefile that Todd had kindly provided and see scientific notation still being displayed plus a bunch of trailing zeros for this one quad sheet index tile.


  • kbelliskbellis Global Mapper User Posts: 417Trusted User
    Going back to the previous workspace to compare information displays, does revel that the check box did make some difference:


  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,776
    Hello,

    I sent you a private message with the info to upload your file via FTP. Thanks. That should be helpful.

    To answer your questions:

    Why isn't the Reformat box checked to begin with by default?

    I thought that it was checked by default.  Further investigation reveals that it is not. I will open a bug to change that.

    And for what it's worth, the check box description isn't exactly clear as it can be interpreted in two ways: "Reformat  Numeric Attribute Values Using Scientific Notation"

    I agree that the language in the option is unclear. The intent is that when the option is checked, attributes that contain text in scientific notation will be reformatted so that they no longer use it. The reformatting logic removes scientific notation when the value is between 1.0e-4 and 1.0e8, which is why your Shape Area attribute is still being displayed in scientific notation.

    Cheers,
    Bob
  • kbelliskbellis Global Mapper User Posts: 417Trusted User
    Hello Bob,

    Thanks for all of your work. I've started the upload to the ftp site. Should be completed soon.

    Kind regards,

    Kelly

Sign In or Register to comment.