Global Mapper Pro

PDF Export Not respecting bounds (draw a box) v19.1

curtcarto
curtcarto Global Mapper User
Hello all,

Since at least GMv19, the export with PDF option export a much larger coverage area than what was selected.

The export doesn't respect the "all data on screen" or the "draw a box" boundaries. 

What used to take seconds to export (small 4"x5" area), now takes 15 minutes because it draws a huge area instead (20"x20").

I'm exporting at:
Letter size
Landcape
At a set scale of 1:3,500,000
Using what's showing on the current screen or the draw a box selection methods.

Anybody help?

Thanks,
.curt

Answers

  • curtcarto
    curtcarto Global Mapper User
    The export size should only be 2"x2".

    Even tried using set lat/long bounds. 

    Still taking nearly ten minutes to export this tiny area.


  • curtcarto
    curtcarto Global Mapper User
    Here's the result, even though the output bounds were the yellow box shown above...

    You can see that it exported SO much more. The small black box is to show what was supposed to export.


  • Mykle
    Mykle Global Mapper User Trusted User
    If any of your layers are downloaded from web sources, they may determine the export resolution value shown in the export dialog.  That resolution is likely to be (much) more than you need and will take lots of time. 

    You can set the resolution to a more appropriate value.  Or you can export each web file to a local file at your desired resolution, with the advantage that you can iterate on finding a resolution value whose export results you prefer.  Then, load your local file(s) and export to PDF. 

    This method (exporting layers that are all local) may have different results with your bounding box (sounds like you are looking at the correct tab in the export dialog). 

  • curtcarto
    curtcarto Global Mapper User
    Hi Mykle,

    They are all local files. 

    Setting aside how slow it exports, the real problem I'm describing and showing here is that Global Mapper 19.2 is not respecting the export BOUNDS set in the export dialog windows. 

    It is exporting much more coverage, more area, than I want. Which only compounds the length of time it takes to export what I need. If it only did the area I want, and did that little bit slowly, it's ok; I need the resolution.

    I only need that little area, shown above in the small rectangle, but it uses the page size (US Letter) and fills the page, even though I have NOT checked on the Fill Whole Page option. 

    So, I think the bug is that it's filling the page, despite that checkbox being off. 
  • bmg_bob
    bmg_bob Global Mapper Programmer
    Hello,

    I agree, that sounds like a bug.  Your best bet is to contact Blue Marble Geographics Support directly via e-mail.  Please include a detailed description of your workflow, and data that will reproduce your problem. Feel free to link back to this thread so the support team can get all of the information you have provided here. 

    Your screen capture indicates that you have several layers loaded, but only one visible.  Do you still get this problem if the visible layer is loaded by itself?

    Cheers,
    Bob
  • curtcarto
    curtcarto Global Mapper User
    Hi Bob,

    The support ticket sounds good. I have another one in related to the PDFs: the page size you use to export affects the scale of the pdf itself. That is, same data will be different sizes if you export with different page sizes (even when all other settings are exactly the same). 

    A instance of GM is right now exporting out the same general area and size, with only that one data layer in the workspace. It's taking a very long time, so I'm going to assume it's doing the whole letter sized page export again.

    I'm focused on the PDF stuff, because we are still making the final maps in Illustrator. I •••really••• want to get away from Arc to do my exporting. So accurate PDFs, or the rumored .ai format, would be primo! 

    Thanks,
    .curt
  • bmg_bob
    bmg_bob Global Mapper Programmer
    Hello,

    One more question: have you tried using the Map Layout Editor to set up your PDF export? You can set the bounds and page size, make sure the page contains the data you want, and export a georeferenced PDF file.

    Cheers,
    Bob
  • curtcarto
    curtcarto Global Mapper User
    Hi Bob,

    Using the Map Layout Edit is where I found the different scales at different page sizes. (and yes, I tried the straight PDF export, the Vector/PDF and the Map Layout Editor, and it still "fills the page" instead of using the bounds I set.)

    Loaded the same file, made three pages of different sizes (but same scale) and the data came out different sizes. 

    I was exporting basic state shapes. Created a letter sized page, a 60"x60" page and a 18"x24" page. All were in the same "portfolio" or whatever it's called. There were all in the same Editor window. All set to the same scale. 

    When all three pages were exported, the lines didn't match up. 

    Attached is the same stuff I sent to the support email, so they know about this page size stuff. There's the setup, three pages. And then the result: aligned in the north west corner, but off in the south east corner. Off by more than enough to show up on a 1:750,000 wall map. Thus, for this older project, I can't switch over to GM to make my exports as they don't fit the (much more sloppy, but consistently scaled) Arc .ai exports.

    Thanks!
    .curt





  • curtcarto
    curtcarto Global Mapper User
    Sorry, page sizes were different from my memory, but you get the idea.

    To be clear: two issues
    1. page size affects output size, even at same export scale (already submitted)
    2. export doesn't respect export bounds box (this issue, will submit to support shortly)
  • curtcarto
    curtcarto Global Mapper User
    Follow up: Same file (and only that file) same setup....and yup, exports the whole letter sized page, not the export bounds box.
  • bmg_bob
    bmg_bob Global Mapper Programmer
    Hello,

    OK. Thanks for the information. When you contact BMG Support, please send them your data file. If it is too large to be attached to an email, they can provide other options.

    Cheers,
    Bob
  • curtcarto
    curtcarto Global Mapper User
    Will do, thanks. It's large but can provide a link for download, etc.

    Thanks again,
    .curt
Sign In or Register to comment.