exporting vector as raster produces no output with error "No data found to export for EXPORT_RASTER"

Hello, I have a problem exporting vector+raster layer as one raster image (.png)

I have a globalmapper package file containing 1 raster and 1 area vector like this:

(or download it here: https://file.io/bo6Igw )

and I have a simple script that exports this project as raster like this:

(or download it here: https://file.io/e4EtH4 )

What happens is when I run this script, nothing is exported and I get an error/warning:
WARNING: No data found to export for EXPORT_RASTER command within specified bounds.

the weird thing is that:
  • when I export this project using GUI - everything works correctly
  • when I run this script with disabled vector layer - the raster is correctly exported
I think that the problem might be that it doesn't export vector layer so I used INC_VECTOR_DATA=YES but looks like it doesn't help.

does anybody know what might be the problem?



Sign In or Register to comment.