Global Mapper Pro

Landsat 8 Geotiff files

I have GM 18 and windows Pro 10 when I open a Landsat 8 Band Geotiff I get an image that looks like a snowstorm from and old black and white television.  What am I doing wrong?
Tagged:

Best Answer

Answers

  • bmg_bob
    bmg_bob Global Mapper Programmer
    Hello,

    You probably need to choose the bands you want to use for display.
    • Right click on your layer in the Control Center and choose Options...
    • Pick the Band Setup tab
    • Choose bands for Red, Green, and Blue, or select from one of the preset band configurations
    Cheers,
    Bob
  • No good.  I right click and get Raster options.  I cant find any band Setup tab.  The tabs are Feathering, Color Grade, Map Zoom, Layer Projection, Display, Color Contrast Adjustment, Cropping.  No Band Setup.  I am trying to use band 8 the high res band 15 meter.
  • bmg_bob
    bmg_bob Global Mapper Programmer
    No good.  I right click and get Raster options.  I cant find any band Setup tab.  The tabs are Feathering, Color Grade, Map Zoom, Layer Projection, Display, Color Contrast Adjustment, Cropping.  No Band Setup.  I am trying to use band 8 the high res band 15 meter.

    Have you updated to the latest released version of Global Mapper 18?

    What do you see for the NUM BANDS in the Control Center metadata for the layer?  Can you post the file here (in a zip archive)?

    Cheers,
    Bob
  • I have the latest version and update says no updates available.  NUM BANDS shows 1. The file is 274,539KB zipped and upload speed available here in remote Alaska is slow but here you go.  I also attached screen shots
  • It looks like the big file upload failed.  I don't think there is anything wrong with the file as I open the exact same file in Manifold GIS with no issues and you can see the screen grab from Photo Paint is clear.
  • Mykle
    Mykle Global Mapper User Trusted User
    Your Photo Paint screen shows that you have a greyscale image, so only one band.  Are you able to load only one band in Photo Paint, so that program is not indicating that you have more bands? 

    Also, note that the Global Mapper display uses what Photoshop would call an "indexed" mode that appears rough although you can zoom in for more detail.  GM does not offer what Photoshop would call a "RGB" mode that is much more smooth. 
  • As far as I know all of the landsat images are displayed as greyscale when initially opened until you change them within a program.  Yes it is only one band, Band 8 which is 15 meter resolution and around 500megs.  As you can see in File Explorer screen shot all of the bands are there each as an individual file.  Attached are 2 screen shots 1 is GM zoomed and the other is Manifold zoomed with the same file to about the same level of zoom.  That is the level I need to utilize.  It makes no sense a GIS program would not be able to work with landsat images.
  • hennie
    hennie Global Mapper User Trusted User
    I use GM 17 extensively to work with Landsat 8 images. Depending on what you want to do, you only have to load the relevant bands (I use bands 4 and 3 for NDVI calculations or bands 7,5 and 3 for "natural colour) in GM. I then use the raster calculator to combine the bands in the way I want them,

    You can also pan-sharpen the created image by using band 8.

    I usually use an external program freely obtainable from www.BigDataEarth.com to pan-sharpen the images in one go, with excellent results.
  • hennie
    hennie Global Mapper User Trusted User
    Sorry, in the NDVI formula, the appropriate bands are bands 5 and 4
  • hennie, I use band 8 primarily as a tool for river channel and glacier location.  So I am just using the most recent downloaded image with only brightness and contrast correction.  When you use it does the image come out as grainy (pixelated) as the screen grab above shows.  I use band 8 for the higher resolution so no need to pan sharpen because it is already 15 meter resolution.  In Manifold Gis you can see that it is just as clear as if opened in Photo Paint.
  • bmg_bob
    bmg_bob Global Mapper Programmer
    Hello,

    We have done some testing locally, and it appears that there is a bug that is preventing the Landsat files from displaying correctly.  We opened bug #20880 to track this problem, and we will post a message on this thread when it has been fixed.

    Cheers,
    Bob
  • bmg_mike
    bmg_mike Global Mapper Guru Trusted User
    I am not able to see any issues with the latest v18.1 build from http://data.bluemarblegeo.com/downloads/global-mapper/dailybuilds/ . The options tab of interest is the Color/Contrast Adjustment tab as this is a 16-bit per sample file, so some adjustment needs to be done to convert the 16-bit grayscale to 8-bit for display.

    The snowy image looks like what happens when just the lower 8 bits of the 16-bit value are used, so the values fluctuate wildly. However for this image even with no Contrast Adjustment GM should be dividing the values by 256 rather than taking the lower 8 bits, so the snowy image shouldn't happen in 18.1. Either of the contrast modes (i.e. standard deviation stretch or min/max stretch) should work as well.

    In my opinion, you get the best results by using the min/max stretch and also making black transparent on the Display tab of the Options dialog.

    If you still have trouble can you save a workspace (.gmw) file with the TIFF loaded and the snowy display so I can confirm what settings are used?

    Thanks,

    Mike
    Global Mapper Guru
    geohelp@bluemarblegeo.com
    http://www.bluemarblegeo.com/
  • No change and I get "Uploaded file type is not allowed" when I try to attach the .gmw file
  • I emailed the gmw file to geohelp@bluemarblegeo.com
  • bmg_mike
    bmg_mike Global Mapper Guru Trusted User
    Ah I do see a problem with the particular Landsat8 tile that you are using, just not the sample one we had here for the bug. I'll see what the problem is and fix it ASAP.

    Thanks,

    Mike
    Global Mapper Guru
    geohelp@bluemarblegeo.com
    http://www.bluemarblegeo.com/
  • hennie
    hennie Global Mapper User Trusted User
    Mike,
    Does the same problem exist in GM 17? If so, will it also be fixed?

    Hennie Schoeman
  • bmg_mike
    bmg_mike Global Mapper Guru Trusted User
    Hennie,

    No the issue wasn't added until v18.1. It should only affect tiles identified as Landsat8. The _MTL.txt file provides the metadata that helps identify it (the absence of that file in my test case was why I couldn't initially see the issue).

    Thanks,

    Mike
    Global Mapper Guru
    geohelp@bluemarblegeo.com
    http://www.bluemarblegeo.com/
  • Works great now thanks Mike
Sign In or Register to comment.