"No Features were Found in the Selected Area" error message when copying attribute between two areas

ufocnadaufocnada Global Mapper UserPosts: 2Unconfirmed
I have two area features, smaller one is completely inside another bigger one, I want to copy attribute of smaller area's attributes to bigger area, I Select the bigger area feature first and then use the function of "Copy Attributse Between Overlapping/Nearby Features" and then select copy Attributes From Loaded Area Features to Selected Area Features, the select "Keep Attributes from First/Closest Matching Feature", then select "Completely Inside a Selected Area"  the error message said "No Features were Found in the Selected Area" The smaller area feature is really completely inside bigger one, what I did wrong?

Answers

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,960
    Hello,

    I was able to reproduce this behavior in Global Mapper 18.  It appears that the text of the option "Completely Inside a Selected Area" is misleading.  Generally, this function assumes that the area you are copying from contains the area you are copying attributes to, and these coverage options operate under that assumption.  In your test case, the opposite is true -- the area you are copying to contains the area you are copying from.  If you choose the option "Any Overlap with a Selected Area Allowed", then the attributes will be copied successfully.

    Cheers,
    Bob
  • ufocnadaufocnada Global Mapper User Posts: 2Unconfirmed
    Hi Bob, thanks for your response, you mean you did it successfully? I have tried again in version 17 and 18, it still doesn't work even i have set the same attribute for two areas. I have to select "Completely Inside a Selected Area" instead of "Any Overlap with a Selected Area Allowed", because there are other areas overlap but not completely inside, I only want to copy the attributes of the area completely inside.
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,960
    Hello,

    When copying attributes between areas using the overlap options, Global Mapper assumes that the FROM area contains the TO area, so when you choose "Completely Inside a Selected Area", Global Mapper checks to see if your TO area is completely inside your FROM area.  In your example, the opposite is true -- the FROM area is inside the TO area, which is why you get the error message.  At this time, the only way to do what you are looking for is to choose one of the other overlap options.

    We have an open feature request to (#14315) support what you are trying to do.  I have added your information to the feature request, and we will post a message on this thread when the status of the feature request changes.

    Cheers,
    Bob
  • ufocanadaufocanada Global Mapper User Posts: 1Unconfirmed
    Thanks very moch
Sign In or Register to comment.