How to Import .csv data in (x,y,-z) format in GM v18

Hi all

I am a complete newbie with Global Mapper and constantly getting an error of "No data could be loaded from the following file". The .csv has one column with everything in, separated by "," for example 
351527.38,5909808.13,-12.57

Each .csv has 50,000 rows but just loading one is proving impossible. I have been looking around on tutorials and removing the -from the z, putting each attribute into it's own column. 

Now I'm doing a test because the .csv originally was saved down from an .xlsx. Textpad shows that "speech marks" are put around the data "351527.38,5909808.13,-12.57". Would GM throw a wobbly if it has these in? Does anyone have any other suggestions?

Cheers,
Wallen

Best Answer

  • MykleMykle Global Mapper User Posts: 446
    Answer ✓
    Wallen,
    Instead of saving your XLSX file to a CSV format, create a blank text file in a plain text editor (TextPad is perfect), then copy the content from one sheet of your spreadsheet and paste it into the text file.  (you can use ctrl-A to select all columns and rows, or you can click on the cell at the top left where the row and column labels meet, or you can select only the rows and columns you like)  Save your text file.

    Open your text file with Global Mapper.  If your file contains only points, make that selection.  If your points form a line, use the lines and points selection.  The other default settings should work, at least for a first pass.  On the second dialog, ensure that you select the UTM projection with the appropriate zone. 

    I usually have many columns of data in addition to easting, northing, and elevation.  A spreadsheet is very useful to rearrange the columns as needed, then cut-and-paste into a text file that Global Mapper imports without problems. 

Answers

  • WallenWallen Posts: 2
    Hi Mykle

    Thank you very much for your reply and for running through the process. It all works now, feel a bit silly for not going down the Textpad route in the first place!

    Thanks again, have a good one.
    Wallen
Sign In or Register to comment.