Global Mapper Pro

How to convert raster/grid elevation data to a TIN

hover
hover Global Mapper UserTrusted User
I have a grid elevation layer (imported GeoTIFF DSM) and I need to export this elevation data as a TIN (triangulated irregular network in DWG-format). 
How can I do so? How can I convert an elevation raster/grid layer to a TIN using GlobalMapper v17 or v18?
Tagged:

Comments

  • bmg_bob
    bmg_bob Global Mapper Programmer
    Hello,

    There is not really a way to go directly from an elevation grid to a TIN.  You would need to create a point at each elevation grid cell center (in Control Center's Layer menu in GM 18), then use the created 3D points to create an elevation grid (in the Control Center's Analysis menu).  Be sure to specify the option to save the TIN as a vector layer.  Then you can export the TIN layer as a DWG file.

    Cheers,
    Bob
  • hover
    hover Global Mapper User Trusted User
    I tried to do this with GM v17 and with v18 but it fails.

    Creating point features seems to work (although I don't see any points) but then, upon step 2, creating an elevation grid from these points fails with a very generic message "Failed to generate any elevation grid tiles."

    What might be wrong?
  • Mykle
    Mykle Global Mapper User Trusted User
    With an elevation grid loaded, use Layer > Create Point Features at Elevation Grid Cell Centers.
    You should see a new layer added showing the number of points that were created, and you should see the points being displayed. 
    Then use Analysis > Create Elevation Grid from 3D Vector / Lidar data
    On the dialog, Grid Method should be Triangulation, and Save Triangulation Network should be checked.
    You should see a new group added to the layer list, containing the elevation grid and the TIN. 
    I don't know if there are any special needs for exporting to a DWG file, and I didn't test any further. 
  • hover
    hover Global Mapper User Trusted User
    > With an elevation grid loaded, use Layer > Create Point Features at Elevation Grid Cell Centers

    Exactly what I did, a new feature layer is created, with millions of point(?) features.

    However, these features are not displayed nor can I select them. I don't see anything of them, these points are kind of zombie features... I can however zoom to this feature layer and the zoom area looks reasonable.

    But trying to do anything else with these point features fails, including creation of a new elevation grid...

    What's wrong?
    How can I analyse these point features?
  • Mykle
    Mykle Global Mapper User Trusted User
    Since I'm not seeing your problem, we are getting into potential issues with Global Mapper other than listing steps to follow, so there are a few details to take care of. 

    First, ensure that you are running the latest-and-greatest version for both your v18 and v17 installations.
    V18 daily builds are at: daily builds 
    V17 most recent setup files are at: setup files

    When you are running the current versions, and the problem is still present, recommend that you create a set of sample data that is probably smaller than your complete file, then post here the metadata for your elevation layer, and for your generated-points layer for picky people to inspect.   Please ensure that you include the version and build number from the top border of the Global Mapper window. 

    Otherwise, we are left with Bob's standard response:
    "I recommend that you send an e-mail describing your workflow and the results, with a copy of your sample data to Blue Marble Geographics support (geohelp@bluemarblegeo.com).  This will ensure that the support team sees the problem and can provide you with a timely response. "

    The support team is pretty focused and helpful.  The sooner that you can describe your problem while using current version(s), and provide data files that allow them to recreate the problem, the sooner you will have a response. 



  • hover
    hover Global Mapper User Trusted User
    I filed an issue, attaching a very small workspace allowing reproduction.
    Thanks for your help.
  • geomannie
    geomannie Global Mapper User Trusted User
    Hi,

    For what its worth, I have replicated Mykle's workflow on GM 18 on a very large dataset and it works perfectly, including the next set of exporting a DWG file, which I can them re-import. Your problem must thus be something specific to your set-up.

    Sorry if this is not helpful

    Cheers
  • hover
    hover Global Mapper User Trusted User
    SOLVED. GM support found the problem :-)

    From recent tests with the lidar module I had a lidar point filter enabled, which prevented the (lidar) points generated from being taken into account for display, selection and grid generation.
Sign In or Register to comment.