Run Script in x64 from x86

NeilNeil Global Mapper UserPosts: 29Trusted User
Hello
I'm trying to automate some data downloading and processing and have run into a road block running a script within a x64 instance of GM, from a script started in a x86 instance of GM (both GM V17.2, Win 7 x64 machine).  I am doing this as i am needing to start with data from and ESRI GeoDatabase, but be left with reasonably sized shape files. So i start by loading the GeoDatabase in x86 (i also have ESRI Arc installed), then exporting geographically separated shape files. In order to reduce file size i am looking to remove a large number of attributes from the shape files, but x86 doesn't have enough memory (I have 24gig RAM and 4gig of virtual memory and 1Tb HDD). I have been able to start a x64 instance from within my first script file; however, I cant seem to get that instance of GM to run a script to load and process the data. Every time i run the following script i get an "Unknown Variable" error from the section referencing the gms, or the data loads into the x86 GM instance from which the script started (and is still running)

This is my script:
RUN_COMMAND COMMAND_LINE="C:\Program Files\GlobalMapper17_64bit\global_mapper.exe" "C:\_Transfer\zz_Load.gms" WAIT_FOR_COMPLETE=NO

i have tried to review the Batch Mode and RUN_COMMAND sections of the scripting reference to come up with some variations but seem to be stuck, so any help would be greatly appreciated.
Tagged:

Answers

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,180
    Hello,

    What kind of Esri GDB are you loading?  If you are loading vector data from a personal GDB (.mdb file) or a file GDB (.gdb folder) that was created using ArcGIS 10 or later, then you can import it using the 64-bit version of Global Mapper without the requirement to have ArcGIS installed.  That would allow you to use the 64-bit version throughout your work flow, and an EMBED_SCRIPT command instead of the RUN_COMMAND.

    Cheers,
    Bob
Sign In or Register to comment.