Global Mapper v25.0

Raster Export Stability Issues

I am having constant crashes and instability issues during raster export on 3 different machines. The same issues existed in V17.1 as well as 17.2. The errors are all of the same kind so are not machine specific but inherent within the program. I am unable to do unattended raster exports of any large area without a crash occurring within the first hour.

I have been using PCs for 30 years and I have tried every trick I know for any potential causes, Turned off DEP, Ran as administrator, uninstalled, reinstalled, repaired, etc etc etc. The instability is also temperamental... the other evening I was able to have an export run overnight without any errors. Why did that work but the next day instability was back? Not running any antivirus or any other software that could be interfering. 2 of the machines are brand new bare bones Dell Inspiron machines. The instability was there from the time I first booted those machines. Updated to latest Visual C++ runtime library (mfc110.dll error), updated graphics card drivers. I've done it all.

I am trying to export primarily imagery with some vector layers as GeoTIFF.
Windows 7 SP1, 64 bit.
1 machine I7 processor with 12 Gb RAM
2 machines I3 processors with 8 Gb RAM.

The two most common errors are below....

They are often but not always proceeded with an Exception calling HandleThread completed error

Any ideas? Thanks!

Problem signature:

 Problem Event Name:                        BEX64
 Application Name:                             global_mapper.exe
 Application Version:                 
 Application Timestamp:                     57076269
 Fault Module Name:                          dbghelp.dll_unloaded
 Fault Module Version:              
 Fault Module Timestamp:                  4ce7c5ac
 Exception Offset:                                000007fefa40ad70
 Exception Code:                                  c0000005
 Exception Data:                                   0000000000000008
 OS Version:                                          6.1.7601.
 Locale ID:                                             1033
 Additional Information 1:                  0c07
 Additional Information 2:                  0c07c63c433f58c2fec350d493cd1a0c
 Additional Information 3:                  858a
 Additional Information 4:                  858a26b8a92099f2acbfa8a0a71d3d28


Problem signature:
 Problem Event Name:                        APPCRASH
 Application Name:                             global_mapper.exe
 Application Version:                 
 Application Timestamp:                     57076269
 Fault Module Name:                          mfc110.dll
 Fault Module Version:                        11.0.60610.1
 Fault Module Timestamp:                  51b4fccb
 Exception Code:                                  c0000005
 Exception Offset:                                000000000024d2b3
 OS Version:                                          6.1.7601.
 Locale ID:                                             1033
 Additional Information 1:                  0c07
 Additional Information 2:                  0c07c63c433f58c2fec350d493cd1a0c
 Additional Information 3:                  47df
 Additional Information 4:                  47dfb4a1db55a76ebbdb50abd493da


  • bmg_bob
    bmg_bob Global Mapper Programmer

    I recommend that you send a detailed description of your workflow and results (along the lines of what you posted here), along with a sample of your data, if possible, to Blue Marble Geographics Support (  This will ensure that the support team knows about the problem, and will expedite a solution.  Thank you.


  • Mykle
    Mykle Global Mapper User Trusted User
    Are you (attempting to) exporting from an on-line source?  If so, the connection to the remote server (and the remote server) are more likely to be the root problem.  That said, it would certainly be helpful if Global Mapper could handle these issues more gracefully. 
  • Yes I am attempting to download from an online server. If this is the root cause of the problem then, yes Global Mapper should definitely be handling these issues more gracefully. It should not be allowing any connection/communication issues to crash the program. It is frustrating to say the least. I will send the info suggested above to the support team and see what they can come up with.

  • I do believe I have worked out my problem. I have been creating some pretty complicated workspaces with a lot of vertexes and a lot of items per layer with some complicated shape files, buffers, etc etc. I was exporting to raster but at the same time downloading from the server. It only makes sense that the detail of having to process all of the vector stuff while also downloading the imagery and combining it all in a raster would certainly be vulnerable to crashes simply due to the complexity of the files. I altered my workflow to download my imagery first and then using already downloaded imagery to create the raster. Downloading the imagery first it is selected with just a simple rectangle or polygon and I have since had no crashes at all. As soon as I went back to one of my complex workspaces my downloads were crashing the software again. So I think the key is downloading imagery first with simple selections/polygons/rectangles (or at worst case workspaces that are not too complicated) and using the map catalog with already downloaded data.

  • No.... my last post of success was too hasty.... I had left my overnight downloads running only to find out that all 3 had crashed within an hour of having left the office. My selection (and workflow) was just a simple 10 point polygon around an island.

    I'm going to have to go back to plan A and contact the support team directly. I am disappointed that a version "17" of a program has such a basic fundamental flaw. And it is the program and not my systems because it is 3 independent PC's that the same errors occur on. :-(
  • Well I contacted tech support directly but it looks like I didn't even need to. The daily build for 20/5 looks like the programmers were already onto addressing the issue after having read my initial post. (impressed)/ I will say I experienced a lot less crashes with 20/5 build BUT the errors I did get had gone from mfc110.dll errors to StackHash errors which I had not experienced before. Upon looking that up - it was related to DEP. I had deactivated my DEP previously during some trouble shooting and I turned it back on for All Windows Apps only.

    But the program behavior from that point was still problematic. The 64 bit version was continually crashing still. Not as often as previous but was still crashing.

    After messing with all sorts of different 32 bit/64 bit version with and without DEP and with or without other options I came up with a 100% stable configuration that has been downloading and rasterizing all day on 3 machines without a single crash!

    The combination that is working for me with 100% reliability is the 32 bit version with compatibility settings set as Run As Administrator and run this program in compatibility mode for Windows XP SP3. DEP is on - but set to Windows programs only. I believe the other option will make it crash - which makes sense if it is misbehaving in memory.

    That may or may not make sense if you are one of  the programmers reading this... but that is what I have found is working.  If I went back to 64 bit and not the XP SP3 compatibility it will inevitably crash.

    Thanks for being so responsive to this issue. I will say that when it is working - it is one robust piece of software!

    Problem signature:

      Problem Event Name:                        BEX
      Application Name:                             global_mapper.exe
      Application Version:                 
      Application Timestamp:                     573ed57f
      Fault Module Name:                          StackHash_0a9e
      Fault Module Version:              
      Fault Module Timestamp:                  00000000
      Exception Offset:                                9b585a97
      Exception Code:                                  c0000005
      Exception Data:                                   00000008
      OS Version:                                          6.1.7601.
      Locale ID:                                             1033
      Additional Information 1:                  0a9e
      Additional Information 2:                  0a9e372d3b4ad19135b953a78882e789
      Additional Information 3:                  0a9e
      Additional Information 4:                  0a9e372d3b4ad19135b953a78882e789

  • Good news I FINALLY worked out the cause of all the raster export stability issues and excessive memory use that lead to the issues. The issue is that GM doesn't like exporting imagery within complex polygons, such as a detailed coastline. Memory use can go up to 7.5 Gb during download and export with a complex polygon. When I reverted to just exporting squares or rectangles of imagery the peak memory use I could muster was about 250 Mb. So for any users experiencing the same issue - do away with the complex polygons during download. Instead export normal rectangular areas and you can bring the tiles back in via map catalog and do all of your polygon work with "offline" imagery.