Global Mapper Pro

Need help on DEM generation

wmiswm
wmiswm Global Mapper UserTrusted User
I have elevation vector data from spot height, contour line of 2m interval, and ponds and lakes polygons of known elevation. If I use all default settings for elevation grid generation, the so generated DEM is not very accurate. What I mean is that, say along a contour line of 232m, I can read elevation deviation of more than about 15m, i.e. from 247m-217m. This is more than 5 contour line intervals, which is quite unacceptable. I wish to enquire how can I make the DEM more adhere to my elevation data. There are some checkboxes and a slider that I can adjust for the DEM output. Specifically, 1. what will be affected by checking and unchecking the "use 3D line feature as constraints" and "flatten 3D area features"? 2. how will the slider affect the DEM output? Will sliding to the left make the DEM more adhere to my original elevation data? 3. will GM really use contour lines for triangulation? Meaning that if I generate points with elevation data along the contour lines, will it help to make GM know to use the contour line elevation data for elevation grid generation? Apart from the inaccuracy as described above, I also encountered another problem during elevation grid generation. My set of elevation data is very detailed, meaning very complicated. If I include polygon elevation data into the calculation, GM will gradually use up all my physical ram of 32GB and then report error after hours of calculation, irrespect of whether I select direct grid output or not. Have I missed anything, or is there any trick that I can bypass this bug?

Answers

  • bmg_bob
    bmg_bob Global Mapper Programmer
    What version of Global Mapper are you using? If you are using v16, have you updated to the latest released version? If the problem persists in the latest version, please send a description of your workflow, a copy of your data (if possible), and the results to Blue Marble Geographics Support (geohelp@bluemarblegeo.com). This will ensure that the support team will be notified of the problem and can work on a solution.
  • wmiswm
    wmiswm Global Mapper User Trusted User
    so besides the hang error, any suggestion on the accuracy issue?
  • Line features only use the elevation values at the vertices to generate an elevation grid using a TIN. If your results are not desirable, you can insert extra vertices into the line or polygon features. 

    First select the features with the digitizer tool, then right click and to go Move/Reshape Features...> Resample/Split Selected Feature(s) at Specified Spacing...
    There a few options for adding vertices, but you could for example 'Sample Features at Fixed Distance Interval' to add vertices. 

    Now when you go to Analysis>Create Elevation Grid from 3d Vector Data there will be many more points included in the Triangulation Network (TIN).

    If you need further suggestions for a particular dataset, please send a copy of your data and workflow to Blue Marble Geographics Support (geohelp@bluemarblegeo.com) 
Sign In or Register to comment.