Losing Feature Label Names when Exporting as KMZ

SwoodySwoody Global Mapper UserPosts: 97Trusted User
edited May 2015 in Technical Support
Hi all,

I am importing CSV files and then exporting as KMZ. In the Control Center, I have been selecting the CSV layer > Options > (Feature Types / Labels / Elevations) > Setup Feature Display Label > Use Multiple Attributes for Names. Hit Apply and OK. Perfect!

But when I export the KMZ and view in Google Earth, the NAME is not there - always manifests in"Point Feature" folders as (no name).

How can I get the Feature Names to export?

Many thanks for any suggestions!
Sara

Comments

  • MykleMykle Global Mapper User Posts: 434Trusted User
    edited May 2015
    Sara,

    Without seeing what labels your CSV is using, and how you have configured Global Mapper to display names, it is difficult to provide a good response.

    So we'll beat around the bush a bit. Note that attribute export often expects particular labels, so changing yours to match may help. Also, Global Mapper provides a few ways to select labels for display, if you haven't explored those options. These selections are often included in exported files, and others are not.

    You can also look at the problem from the other end, by creating a few similar features by hand in Google Earth and exporting the results. If you get a KMZ file, remember that these are simply zipped KML files, so you can rename the KMZ to ZIP and extract the KML for inspection. You may discover labels that Google Earth prefers, so you can tweak your CSV column labels.

    When you do get labels to appear in Google Earth, you may find them to be large and intrusive. You have options in properties for selecting the font size, all the way down where none will be displayed.

    Good luck!
    Mykle
  • SwoodySwoody Global Mapper User Posts: 97Trusted User
    edited May 2015
    Hi Mykle,

    I finally figured it out! I always have "Display Labels for Layers if Any Shown" UNCHECKED, because they are intrusive, and take over my screen. Turns out, when I export, it just ignores my naming all together and gives it a generic name, instead of just not "displaying" them.

    Thank you for your informative response - much appreciated!

    SARA
Sign In or Register to comment.