issue w/ transparent pixels in batch conversion

vieuxdelamontagnevieuxdelamontagne Global Mapper UserPosts: 66Trusted User
edited August 2014 in Raster Data
This seems similar to several other recent threads, but I'm not seeing a solution/explanation in the forum. Apologies if I've missed something.

If I proceed manually (one file at a time), I can load a GeoTIFF, trim the collar "automatically", reproject to UTM, and export the result as a GeoTIFF with transparent pixels replacing the background. (The reprojection to UTM necessarily skews the image slightly, so that there IS a background even after trimming the collar.)

This works fine. Trouble is, I have more than five hundred files I want to trim and reproject. It seems to me I ought to be able to achieve this in either of two ways: (1) using "Batch convert/reproject" or (2) using scripting. After many, many trials, I have not been able to get the background pixels to be written as transparent using either the background transparent option in batch convert or the BG_TRANSPARENT=YES parameter setting in EXPORT_RASTER.

Any idea what I'm missing? GM 15.2.2 64-bit b052714; Windows 7. Thanks.
Sign In or Register to comment.