Global Mapper Pro

option for not adding unit of measure when displaying feature measurements

JSL
JSL Global Mapper UserTrusted User
edited July 2014 in Suggestion Box
Hi, I'm working with a lot of polygons for which I use the Display Measurements command to export to a CSV file. I then use a chart visualization program to make graphs, but it can't use the <Enclosed Area> numbers as measurements unless I remove the "sq km" or "km" text in the CSV file, which can be time-consuming, especially when I have to re-create the CSV multiple times because of making corrections. Is it possible to have the option "Would you like to append a unit of measurement" work with the Display Measurement command for the <Enclosed Area> and <Length/Perimeter> parameters?

Thanks for any help.

Comments

  • samknight
    samknight BMG Staff
    edited July 2014
    Hi JSL,
    You can actually do this already in the measurement preferences. If you click on the measurement tool and then right-click on the map to open the measurement preferences, the last option in the second group of settings is "Append Unit Name to Measure Attribute Values". If you disable that option (it is on by default) when you calculate your lengths and areas, they will be added with no additional labels.

    Regards,
    Sam Knight
    Director of Product Management
    Blue Marble Geographics
  • JSL
    JSL Global Mapper User Trusted User
    edited July 2014
    Thanks so much for that information--my charting life just got a whole lot easier!
  • JSL
    JSL Global Mapper User Trusted User
    edited July 2014
    Is there a way to turn off the option to display the total area and perimeter length at the bottom of the results generated by the DISPLAY MEASUREMENT command? That's another two lines that I have to get rid of before charting. No big deal if it's not possible, just thought I'd check.
  • samknight
    samknight BMG Staff
    edited July 2014
    Hi JSL,
    There isn't a way to disable that from that particular method right now, but there is a different workflow that will deliver the same results without the totals. If you use the right-click method to add the measurements as attributes, if you then open the search by attributes dialog, you can select all features listed and right click to copy as text, then paste that into a text document. That's not quite as few clicks as the Display Measurements dialog, but will also get you there. If you are doing this on a large number of features, you may encounter a popup that indicates your text is too big to copy to the clipboard. If you see this you will also have the option to write directly to a CSV file. Does that help your workflow?

    Regards,
    Sam Knight
    Director of Product Management
    Blue Marble Geographics
  • JSL
    JSL Global Mapper User Trusted User
    edited July 2014
    Hi Sam, I tried that, and the amount was too big to copy to the clipboard, but I didn't get the option to write to a CSV file, just to a text file. When I tried to open the file with Excel, the file was not comma delimited, just lines of parameters separated by commas. Am I missing a step?

    Thanks for your help.
  • samknight
    samknight BMG Staff
    edited July 2014
    Are you on the latest release? I believe this was a recently added change in 15.2. You can download 15.2 from:
    Global Mapper Downloads

    Regards,
    Sam Knight
    Director of Product Management
    Blue Marble Geographics
  • JSL
    JSL Global Mapper User Trusted User
    edited July 2014
    Hi Sam, I downloaded the latest version and tried again, and got the copy to text command to work by manually adding .csv to the name of the file when I saved it. However, when I tried to copy from the Search window on a smaller dataset, I was able to copy it completely, but when I pasted the snippet into a blank excel window, I still got a series of parameters and commas. Attached is a screenshot of that file.
  • samknight
    samknight BMG Staff
    edited July 2014
    Hi JSL,
    When pasting, you could paste into a text editor (I use Notepad++) and save as CSV. The CSV would then open in Excel using the appropriate comma delimited column separations. If you want to paste directly into Excel, you would need to paste it in and then use the "Text to Columns" dialog on the Data ribbon to have it acknowledge the comma delimiters. This may be different in your version of Excel, as those functions have changed a bit in the various releases, it actually used to be easier. Personally, I find pasting into a text editor faster, with fewer steps, but the direct to Excel method will also get you there. I hope one of those helps you out.

    Regards,
    Sam Knight
    Director of Product Management
    Blue Marble Geographics
  • JSL
    JSL Global Mapper User Trusted User
    edited July 2014
    Thanks, that works. Thanks for all your time with this issue.
Sign In or Register to comment.