Voronoi diagrams help

Radon222Radon222 Global Mapper UserPosts: 21Trusted User
edited July 2014 in Technical Support
hello all,

I'm trying to create Voronoi diagram from some point data within a define polygon. I think I'm running the process correctly, but the analysis seems to be not include some of the points. See the attached screen capture.
Voronoi.PNG




The border and points were provided to be me as a DXF file. I've tried working directly from the DXF. I've separated the point and area features and imported to GM separately...all with the same results.


Does anyone have any other suggestions?

Thanks
Ed DeAngelo
(GM 15.2 build 051914 64bit) (+GEM)

Comments

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,002
    edited July 2014
    Hi Ed,

    Thank you for using Global Mapper. Can you upload your DXF file and a screen capture of the Voronoi diagram dialog? I will take a look to see if I can determine what is going on.

    Thanks,

    Bob
  • Radon222Radon222 Global Mapper User Posts: 21Trusted User
    edited July 2014
    bmg_bob wrote: »
    Hi Ed,

    Thank you for using Global Mapper. Can you upload your DXF file and a screen capture of the Voronoi diagram dialog? I will take a look to see if I can determine what is going on.

    Thanks,

    Bob

    Bob,

    Thanks for the offer of help! Here is the zipped up DXF file. Note that the polygon boundary was not delivered as an Area feature. I used GM to create the AREA.

    But... whether using a bounding area or not, the most northerly and southerly points weren't included.
  • Radon222Radon222 Global Mapper User Posts: 21Trusted User
    edited July 2014
    Ok I played around with it a little more. Choosing output type as Line Segments instead of Polygons works a bit better. The analysis shows it at least is using those points. The only downside is that the line segments are not extended all the way to the bounding area...

    Voronoi_LS.PNG
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,002
    edited July 2014
    Hi Ed,

    I fixed this so that the lines that make up the Voronoi diagram will extend to the edge of a selected polygon. To make this work, you will need to select the polygon before choosing the Analysis->Create Voronoi/Thiessen Diagram menu option. On the Voronoi options dialog, click the Bounds... button and select the option to crop to the selected feature (I think you were doing this already, anyway.)

    You can find new builds with the latest changes at the links below:


    32-bit: http://www.bluemarblegeo.com/downloa...l_mapper15.zip
    64-bit: http://www.bluemarblegeo.com/downloa...er15_64bit.zip

    Simply download the .zip file for the build that you are using and extract over your existing installation files (do not uninstall your current version of Global Mapper). The likely locations to extract to are as follows:

    32-bit: C:\Program Files (x86)\GlobalMapper15
    64-bit: C:\Program Files\GlobalMapper15_64bit

    Cheers,

    Bob
  • Radon222Radon222 Global Mapper User Posts: 21Trusted User
    edited July 2014
    Thank you!

    That works great for the Line segment option. Which gets us what we need. But the Polygon output option still misses those same points. Is that an inherent nature of the analysis algorithm itself?
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,002
    edited July 2014
    Hi Ed,

    I will take another look at the polygon processing to see if I can figure out why those points are not included.

    Cheers,

    Bob
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,002
    edited July 2014
    Hi Ed,

    The Voronoi code produces "unbounded" faces for the points that are not covered by polygons, and we currently don't have a good way to represent them unless Draw Data Boundary is checked. In that case, we can make an area using points where the lines intersect the bounding box. If you check Draw Data Boundary and also click Bounds... and chose Crop to Selected Feature(s), you will get a polygon representation of the Voronoi diagram that fits inside your area feature.

    Cheers,

    Bob
Sign In or Register to comment.