Label Background Fill Mode not working

JakeJake Global Mapper UserPosts: 276Trusted User
edited July 2013 in Technical Support
GM 14.2 b070913 64 bit
W7 64 bit

I have some symbolized point features with labels and some text blocks (using TEXT Feature type). I want to mask the vector data that falls under the text. I set the text layer to "Fill With Background Color". The screen does not reflect this. Exported PDF does not mask the lines either. Is this not the purpose of the option or am I misunderstanding something? My background color is white.

On a related note, for vector data does the order of the layers in the Overlay control Center have any impact on masking?

Comments

  • JakeJake Global Mapper User Posts: 276Trusted User
    edited July 2013
    Ok I have discovered that once I switch 'Label Position Relative to Point Feature' from AUTOMATIC the problem starts. Since I want the text block to remain static I have to set something other than automatic.
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited July 2013
    I am so far unable to reproduce this. If I set the font for a point to fill with the background color that is being obeyed every time, regardless of the position setting. Can you provide a sample data set that reproduces this?

    Depending on the Vector Layer Ordering During Draw setting on the Vector Display tab of the Configuration dialog the labels are either rendered all at once at the end in the order the labels were placed, or they are drawn a layer at a time. If you switch that setting you can have each layer rendered independently in the order they are arranged in the Control Center.

    Thanks,

    Mike
    Global Mapper Guru
    geohelp@bluemarblegeo.com
    Blue Marble Geographics for Coordinate Conversion, Image Reprojection and Vector Translation
  • JakeJake Global Mapper User Posts: 276Trusted User
    edited July 2013
    See attached sample which contain only 2 features. One line and one text block (point). Currently I cannot see the text as it is placed at the line intersection.
  • JakeJake Global Mapper User Posts: 276Trusted User
    edited July 2013
    OK this is strange. Since creating the sample it is now working in the other project. It is possible the toggling of the "Vector Layer Ordering" had some effect on the other project I had open?

    Also, I noticed I did not have "Always Display Label" option checked in the sample I attached but in my mail project it has always been checked.
  • JakeJake Global Mapper User Posts: 276Trusted User
    edited July 2013
    Ok now it is masking during draw but not during PDF export. See attachment.
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited July 2013
    I have updated the PDF export to blank out the box behind text marked as having the background filled. Currently this only works for non-rotated text. I have placed a new build at http://www.bluemarblegeo.com/downloads/global-mapper/global_mapper14.zip with the latest changes for you to try. Simply download that file and extract the contents into your existing v14.xx installation folder to give it a try. If you are using the 64-bit v14 version there is a new build at http://www.bluemarblegeo.com/downloads/global-mapper/global_mapper14_64bit.zip .

    Thanks,

    Mike
    Global Mapper Guru
    geohelp@bluemarblegeo.com
    Blue Marble Geographics for Coordinate Conversion, Image Reprojection and Vector Translation
  • JakeJake Global Mapper User Posts: 276Trusted User
    edited July 2013
    Super. Thanks Mike.
Sign In or Register to comment.