Import AutoCAD .dxf file problem

DGriffithDGriffith Global Mapper UserPosts: 70Trusted User
edited July 2013 in Vector Data
I am having problems importing AutoCAD .dxf files to GM 14.2 64 bit. Sometimes it works fine, sometimes all I get is points. There are blocks in this file. As an example attached is a small AutoCAD .dxf file that does not import properly. It is in AutoCAD R12 .dxf format. Later versions of AutoCAD files seem to have problems sometimes too, which is why I am using the earliest version .dxf that still comes with AutoCAD.

Am I doing something wrong, or is there a bug?

Thanks in advance.
David

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited June 2013
    David,

    I see line outlines and a couple of points when I load this file, but the lines are white so they can be hard to see. You might check your background color under the View menu and make sure it is something that white shows up on. We also just fixed a bug loading some DXF files, so getting the latest build might help. I have placed a new build at http://www.bluemarblegeo.com/downloads/global-mapper/global_mapper14.zip with the latest changes for you to try. Simply download that file and extract the contents into your existing v14.xx installation folder to give it a try. If you are using the 64-bit v14 version there is a new build at http://www.bluemarblegeo.com/downloads/global-mapper/global_mapper14_64bit.zip .

    Thanks,

    Mike
    Global Mapper Guru
    geohelp@bluemarblegeo.com
    Blue Marble Geographics for Coordinate Conversion, Image Reprojection and Vector Translation
  • DGriffithDGriffith Global Mapper User Posts: 70Trusted User
    edited June 2013
    Thanks Mike, as always you are able to get me going in the right direction. You have no idea how many different ways I tried to import the AutoCAD files and never once noticed or thought that the problem might be the background color.
  • ns2000ns2000 Global Mapper User Posts: 3
    edited July 2013
    I export dxf/dwg files out of General CADD and when I open them in Global Mapper the black lines turn white. I know this is an old autocad issue, but I was just wondering if there was a setting somewhere that would change that. Maybe a toggle that would switch black and white? ....Or you could work out a deal with General CADD so Gloabal Mapper could open their files. I know sharing file formats is not that easy, but a guy can dream.
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited July 2013
    Can you provide a sample from General CADD? It could be they stick something in the header so we can identify the files from them and know to use the old palette with the wrong black/white entries.

    Thanks,

    Mike
    Global Mapper Guru
    geohelp@bluemarblegeo.com
    Blue Marble Geographics for Coordinate Conversion, Image Reprojection and Vector Translation
  • ns2000ns2000 Global Mapper User Posts: 3
    edited July 2013
    dxf is attached.Black Line.zip
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,057
    edited July 2013
    Hi,

    I opened the attachment in both Global Mapper 14.2.2 and AutoDesk TrueView 2014, and I saw a vertical black line. Is that what I was supposed to see? Was it a white line in General CADD?

    Cheers,

    Bob
  • ns2000ns2000 Global Mapper User Posts: 3
    edited July 2013
    Well I loaded it up and it came in just fine. I tried and tried to load a file yesterday and all my black lines turned white. After a little bit of checking I believe the problem is with the acad release version. Evidently I saved the problem file as an older version while the black line I sent you was R2013. I exported the problem file as a R2013 and it also comes in just fine now. Sorry. Thanks for the wonderful support.
Sign In or Register to comment.