Global Mapper 15
Results 1 to 5 of 5
  1. #1
    Vik
    Vik is offline
    Global Mapper User
    Join Date
    Apr 2012
    Posts
    14

    Default Trouble importing NAIP imagery data

    My site has a registered version of GlobalMapperv12, and I'm new to the product. What I'm trying to do is import NAIP data into GlobalMapper for conversion into a format that an in-house application can make use of. However, I'm having a bit of trouble with the first step of importing the raw NAIP data into Global Mapper.

    I go to the "File" pulldown menu, and from there selected "open data file(s)". I have many files in my directory but the only ones visible under the default "support commonly used" mask are my .sid files and .shp files. The .shp files can be opened without error, but when I try to open the .sid ones I get the following error:

    "Unknown error while rendering overlays, you should probably save and quit.
    mrsid format error [2005]"

    Then it prints out the path to the filename I'm trying to open, a series of seemingly random numbers, and then a sourcecode filename and line number: MrSIDOVerlay.cpp - 550. It gives my version number as v12.02 and a Build time of May 12 2011 00:52:07

    That's pretty much it for the error message. I have NAIP data for multiple counties in Nevada (Douglas, Lander, and Lyon) downloaded, and I'm getting the same error for all of them. If it helps, the data is from the ftp link on this website: http://keck.library.unr.edu/Data/NAIP

    The aforementioned ftp site is ftp://dataworks.library.unr.edu/naip/2010/County and I'm pulling the data down through there over filezilla. I had tried to fetch the NAIP data from seamless, but the stingy max download queue on the site kept me from choosing that as my primary source for the data.

    Any help would be appreciated. I've been in industry for some years, but GIS, terrain imagery, etc. is a completely new domain for me, so it is quite probable I am making some very basic errors.

    Thanks,
    Vik

  2. #2
    Administrator
    Join Date
    Jun 2007
    Posts
    16,448

    Default

    Vik,

    I wonder if maybe you are downloading the files in ASCII mode rather than binary or something? I just pulled down the huge Douglas county SID image and it loaded fine for me both in v12.02 and v13.1, so the files seem ok.

    You might also note that you can get NAIP imagery using the File->Download Online Imagery/Data menu command, both through the specific NAIP source, which can be slow as it is from a USGS server, or also from the pre-tiled World Imagery source which might not be the latest NAIP, but is typically much faster.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com

  3. #3
    Vik
    Vik is offline
    Global Mapper User
    Join Date
    Apr 2012
    Posts
    14

    Default

    Mike, I definitely appreciate the quick response. The wrong ftp transfer mode is the first thing I thought, too, and I verified that my transfer type in filezilla was set to "Binary" (not ascii, or even the auto-select mode).

    However, since you downloaded and imported the file successfully, I figured some troubleshooting was in order. I used the windows command line ftp tool to queue up the Douglas .sid. I'll try accessing that in the morning after it's pulled down to see if I have better luck with that. If so, then filezilla was somehow to blame. Mind if I ask what ftp client you used to pull down the Douglas .sid?

    Getting the data directly online from Global Mapper isn't an option for me. My Global Mapper machine is not connected to the wider internet.

    Thanks,
    Vik

  4. #4
    Administrator
    Join Date
    Jun 2007
    Posts
    16,448

    Default

    Vik,

    I used CuteFTP to download the data.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com

  5. #5
    Vik
    Vik is offline
    Global Mapper User
    Join Date
    Apr 2012
    Posts
    14

    Default

    Mike, just wanted to let you know I resolved the issue. A colleague of mine downloaded one county's worth of info onto his machine off of the same ftp server, and we saw the checksums of the .sid files (but only the .sid files) were different. With that big clue being right in front of me, I was certain the problem was with my download, so I eventually was able to figure out what went wrong. Thanks for your help! Wish it had occurred to me to ask you what the checksum of your .sid was--would've saved me quite a bit of time.

    Thanks,
    Vik

 

 

Similar Threads

  1. Bad 2011 NAIP imagery
    By Ice Age Mark in forum Raster Data
    Replies: 5
    Last Post: 02-10-2012, 09:51 PM
  2. NAIP Color Imagery for US Now Built-In!
    By global_mapper in forum Announcement and News
    Replies: 20
    Last Post: 05-12-2011, 10:27 PM
  3. Having trouble importing jpg with .ers
    By ai3d in forum Raster Data
    Replies: 7
    Last Post: 04-14-2011, 04:26 AM
  4. Trouble with importing wilderness.net map data
    By DaveGoodrich in forum Technical Support
    Replies: 1
    Last Post: 11-16-2010, 05:25 PM
  5. Trouble importing .map files
    By planing28 in forum Downloading Imagery
    Replies: 2
    Last Post: 06-26-2009, 12:05 PM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Content Relevant URLs by vBSEO 3.6.1
Copyright 2008-2012 Globalmapperforum.com
All times are GMT. The time now is 02:38 PM.
vBulletin 4.0 skin by CompleteVB