Global Mapper 16
Results 1 to 2 of 2
  1. #1
    Global Mapper User
    Join Date
    Nov 2011
    Posts
    5

    Default Problem with DWG in Global Mapper 13

    Hi!
    I have a problem with a couple of DWG building drawings that I have got from a customer. When opening them in Autodesks own application DWG TrueView 2012 they look fine in wireframe as well as in the shaded or "realistic" view modes.

    This is reported by DWG TrueView 2012 when loading:
    Opening an AutoCAD 2004 format file.
    Regenerating model.
    _RIBBON
    COMMANDLINE
    Autodesk DWG. This file is a TrustedDWG last saved by an Autodesk application
    or Autodesk licensed application.


    When I load the same files into Global Mapper v13.00 (b101711), the 3D wire frame looks OK. The 3D view toolbar button "Wireframe View" is however stuck in wireframe mode. If I push it it just returns to non-pushed state. I can't get a solid view in 3D. This is a minor problem. The major issue I have is when trying to create an elevation grid from the DWG. For some of the files I get a crash in Global Mapper if "Use 3D Line Features as Constraints (i.e. Breaklines)" is checked. Regardless of settings on the tab "Grid Options" I get very strange looking grids. It looks like the wrong vertices have been connected. E.g. buildings with a flat roof will have what looks like a lot of "needles" going from the bottom to the top instead of a flat roof. Also other parts of the buildings are distorted. I have tried different settings for "No data distance criteria" but I can't get a correct elevation grid for the building. I have studied the generated elevation grid both in Global mapper 3D view and in our own application after having exported the elevation grid as GRIDASCII and then imported it into our own application. The resulting elevation grid looks identical in Global mapper and in our own application so I suspect the grid creation algorithm in Global Mapper messes things up.

    I have attached a pdf with screen dumps showing the error.

    I have tested both the 32-bit and 64-bit versions of Global mapper with the same result.

    Is there a setting I have missed or is this a bug?
    Attached Files Attached Files

  2. #2
    Administrator
    Join Date
    Jun 2007
    Posts
    16,451

    Default

    The wireframe setting in Global Mapper's 3D view controls whether a loaded terrain surface is drawn as a solid surface or as a wireframe. It has no effect on rendered 3D vector data like you have. Likewise the operation to grid vector data doesn't really work very well when there are multiple 3D vector features at the same location as which elevation value is used for a particular point can be problematic when there are multiple.

    I think what you actually want is to edit your 3D area feature styles and make them use solid filled styles rather than just drawing the borders, then you will see the solid view in the 3D view and not just the outline (what you might call wireframe) view.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com

 

 

Similar Threads

  1. Replies: 1
    Last Post: 11-14-2011, 04:34 PM
  2. global mapper
    By Lewiiss in forum How I use Global Mapper
    Replies: 1
    Last Post: 01-17-2011, 08:13 AM
  3. Export Contour to DWG scale problem
    By Watermellon in forum Technical Support
    Replies: 1
    Last Post: 11-02-2010, 03:59 AM
  4. Replies: 2
    Last Post: 07-16-2010, 04:03 PM
  5. Global Mapper
    By iskinner in forum Technical Support
    Replies: 1
    Last Post: 04-19-2009, 02:19 PM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Content Relevant URLs by vBSEO 3.6.1
Copyright 2008-2012 Globalmapperforum.com
All times are GMT. The time now is 02:14 AM.
vBulletin 4.0 skin by CompleteVB