Bug in Grid creation process GM V12.02 64bit

Ketan7880Ketan7880 Global Mapper UserPosts: 4
edited March 2012 in Bug Report
Hi,

I have a text file with x,y,z data and the z value is ranging between 0.0000 to 0.016. The Z value is in 10 decimal places.

When I created elevation grid from Data is creating 0 elevation in some areas where there isn't any 0 value. I check the TIN as well but nothing there too. I am not sure what's wrong going in process.

I created DEM in Vertical Mapper with same data and, I got perfect result. I think GM is not supporting more decimal value.

I have attached the raw data as well as grid data which is created in GM and VM.

Regards,Data.zip
Data.zip 721.5K

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited March 2012
    For very tiny high precision data like that I would suggest using a floating point grid format rather than an ASCII one since Global Mapper will truncate the ASCII ones to avoid wasting a large amount of space in files on precision that isn't typically there. If you use the Float/Grid export or maybe a GeoTIFF with 32-bit floating point samples then the full precision should be maintained. Another option would be to provide a Z scaling factor when importing the original XYZ file to bring the Z values up into a higher range.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • Ketan7880Ketan7880 Global Mapper User Posts: 4
    edited March 2012
    I am quite not sure what you says here.
    I have text file, I open that one as point file in GM and after that I created a grid of that point data and I am getting 0 elevation value in some area where there isn't any 0 elevation. How it could be. My question is why I am getting 0 elevation where there is no o elevation in TIN points. I have attached some PICs of that.

    I think you misunderstood my question. There is nothing to do with exporting the grid. It's all about the triangulation process within GM.

    GM Grid 1.jpgGM Grid.jpgVM Grid 1.jpgVM Grid.jpg
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited March 2012
    Ah ok, I see what you are saying. There are some "smarts" in the gridding algorithm to prevent roundoff from causing values very close to zero (less than 0.001) that really should be zero. I have disabled that behavior when the entire elevation spread of what is being gridded is small, which fixes the issue for your data. I have placed a new build at http://www.globalmapper.com/global_mapper13.zip with the latest changes for you to try. Simply download that file and extract the contents into your existing v13.xx installation folder to give it a try. If you are using the 64-bit v13 version there is a new build at http://www.globalmapper.com/global_mapper13_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • Ketan7880Ketan7880 Global Mapper User Posts: 4
    edited March 2012
    Hi,

    I am using GM V12.02.
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited March 2012
    I put the fix in a v12 64-bit build for you at http://www.globalmapper.com/global_mapper12_64bit.zip . Would still definitely recommend upgrading to v13 as there is a ton of cool new stuff in v13 since v12.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • Ketan7880Ketan7880 Global Mapper User Posts: 4
    edited March 2012
    Thanks Mike.
    That perfect for me.

    Thanks a lot for sorting out this one so quickly.

    Regards,
Sign In or Register to comment.