Error exporting MBTILES using a script

Hello good day

I am new to this forum and thank you in advance for any help you can provide.

My query is due to a problem that is occurring with version 18.1.0 of global mapper when trying to make a creation of MBTILES files using a script using the option EXPORT_WEB starting from files in ECW format (EPSG 4326). The script used is the following:

GLOBAL_MAPPER_SCRIPT VERSION=1.00

DIR_LOOP_START DIRECTORY="D:\ORTOFOTOS\PRUEBA\" FILENAME_MASKS="*.ECW" RECURSE_DIR=YES 

IMPORT FILENAME="%FNAME_W_DIR%"

EXPORT_WEB FILENAME="D:\ORTOFOTOS\PRUEBA\%FNAME_WO_EXT%\%FNAME_WO_EXT%.mbtiles"\ 

TYPE="MBTILES" MAX_ZOOM_LEVEL="18" NUM_ZOOM_LEVELS="5" MBT_MAP_TYPE="basemap"\

MAP_NAME="%FNAME_WO_EXT%" IMAGE_FORMAT="JPG"  \

QUALITY="75" TILE_SIZE="256" WEB_FULL_TILES_ONLY="YES"

// Unload the loaded data

UNLOAD_ALL

DIR_LOOP_END


The result obtained is a base with black edges from the minimum zoom to the maximum, despite having used the option "WEB_FULL_TILES_ONLY =" YES .


When the same file is loaded manually in the application and we export using the EXPORT WEB FORMAT option with the options marked "Only Export Fully Covered Tiles" in the "Tilling options" and "All Loaded Data" tab in the "Export bounds" tab, the result is a black borderless base at any zoom level, Which was the desired effect.



I do not know if there is anything that escapes me from putting in the script or something that is incorrect.

Many thanks to everyone who can lend a hand, because I do not know what I can do. 


Answers

This discussion has been closed.