Error setting 3D viewer info

I keep getting this error if I try to use the 'Show 3D View' following/during using the '3D Path Profile/Line of Sight Tool'. 

What I mean is that I have my 3D Path Profile View docked and when I hit the 'Show 3D View' it pops up the error message. It will display the 3D View fine if I don't use the '3D Path Profile/Line of Sight Tool'. If I close the 3D Path Profile View it will then work. However, I notice that my view in the model is then below my elevation grid as it is only showing the 'face normals' of the terrain and culling the back of the normal. Furthermore when I zoom out and back in to correct the view it clips to the Path Profile from before that no longer exists. This is fixed by closing the window and using 'Show 3D View' again.

I am using Global Mapper v17.2 on Windows 7 Ultimate Service Pack 1 with 48.GB RAM installed on a compter the size of a minibar!
The elevation grid I am analyzing was created from a DWG containing survey data points, 3D Polylines and contours. The elevation grid is the only layer on.

Error setting 3D viewer view info.
OpenGL version: 4.5.0 NVIDIA 358.91
Vendor: NVIDIA Corporation
Renderer: Quadro 4000/PCIe/SSE2
Error in SetViewInfo: Error in CreateVectorDisplayLists: Error in RenderPathProfile: Write access violation at data address 0x00000000049D3000,
program address 0x00000000049D3000.


Ctrl3DView.cpp - 12141
Version: v17.2.1 (64-bit)
Build Time: May 27 2016 13:50:36
Windows 7 Ultimate (64-bit) Memory: 41,233,969,152 of 51,537,072,128 available, GDI Usage: 761 GDI (Peak 766), 119 User (Peak 120)

Best Answer

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,686
    Answer ✓
    Hello,

    First, I suggest updating to the latest version of Global Mapper 17 so you can see if this is a problem that has already been fixed.  If the problem persists, you should contact Blue Marble Geographics Support directly via e-mail (geohelp@bluemarblegeo.com).

    Cheers,
    Bob

Answers

  • Hi Bob.

    I have the most recent version of v17.2 therefore I'll take your advice and get in touch with them. 

    Thank you,
    Steve

Sign In or Register to comment.