Export 1 line as KMZ, it breaks into 3 - how to prevent?

SwoodySwoody Global Mapper UserPosts: 97Trusted User
edited February 23 in Vector Data
I have one line. When I export it to KMZ using the following settings, the resulting file has broken the line into 3 lines. 
I am not 'tiling" the data or using any 'export bounds'. Why would this happen?  Can I prevent it from happening?  Unfortunately I cannot upload this particular KMZ.  When I create a random line and export it, it does not break into multiple lines. Do not know what is difference might be.  Thanks in advance for any suggestions!

Using v18.1 (latest build)

Flummoxed in NC,
Sara
Tagged:

Best Answers

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,690
    Answer ✓
    Hello Sara,

    The original line has 20,474 vertices.  When exporting to KML/KMZ, Global Mapper breaks the line up into segments of 8,092 vertices or fewer.  This was done two years ago due to limitations and performance issues in Google Earth.  If you want to make sure that you preserve the single line feature, you can select the line in the Digitizer and use the Vertex Editing | SIMPLIFY function to reduce the number of vertices.

    Cheers,
    Bob
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,690
    Answer ✓
    Swoody said:
    Hi bmg_bob,

    I am viewing a file in Google Earth which has 187,023 vertices, made up of 19 interconnected lines. They are all displaying at the same time with no issue. Is the issue (you speak of) if all vertices are contained on ONE line? 
    Yes, the issue happens when a single line feature contains more than 65,000 vertices.  I have modified the number of features per split line to 65,000 (up from 8,192).  This change will be in daily builds dated Mar 14, 2017 or later (tomorrow as of this posting).  I will also be adding an option to the KML/KMZ Export Options that will enable or disable the feature splitting function, but is not implemented yet.

    Cheers,
    Bob

Answers

  • SwoodySwoody Global Mapper User Posts: 97Trusted User
    edited February 27
    bmg_bob!  Thank you! Wish you folks would consider changing it back, or at least give the user the choice of whether to chop them into smaller units. I have never (ever) had issues in Google Earth with lines that have many vertices. Truly, not once, in all these years. Only time I have performance issues with Google Earth is with too many placemarks, but never an issue with lines and vertices.  

    Unfortunately it is never an option for us to simplify lines - in fact I many times need to add MORE vertices, to "ground" lines and polygons, so they do not visually "float" above or below ground level (using 'Clamped to ground' altitude mode), when we use them in our aerial camera overlay.

    Thank you for the information!
    Sara
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,690
    Swoody said:
    bmg_bob!  Thank you! Wish you folks would consider changing it back, or at least give the user the choice of whether to chop them into smaller units. I have never (ever) had issues in Google Earth with lines that have many vertices. Truly, not once, in all these years. Only time I have performance issues with Google Earth is with too many placemarks, but never an issue with lines and vertices.  

    Unfortunately it is never an option for us to simplify lines - in fact I many times need to add MORE vertices, to "ground" lines and polygons, so they do not visually "float" above or below ground level (using 'Clamped to ground' altitude mode), when we use them in our aerial camera overlay.

    Hi Sara,

    I have been doing some testing with Google Earth, and what I am seeing is that line features that contain more than about 65,000 vertices are not handled properly. They show up in the feature list, but are not visible on the display.  Are you seeing something different?  If so, can you post a sample file that can be displayed in Google Earth despite having line features with greater than 65,000 vertices?  Thanks.

    Cheers,
    Bob
  • SwoodySwoody Global Mapper User Posts: 97Trusted User
    edited March 13
    Hi bmg_bob,

    Thanks for testing! I cannot publicly post my sample, but if there is somewhere I can privately upload it to show you? I am viewing a file in Google Earth which has 187,023 vertices, made up of 19 interconnected lines. They are all displaying at the same time with no issue. Is the issue (you speak of) if all vertices are contained on ONE line?  As a test, I added 100,000 extra vertices to a single line in Global Mapper, but unfortunately it then exports them as multiple lines. So I can't truly test in Google Earth. But that sample (108873 vertex) also has no issues when loaded in Google Earth.

    Also - if you see the issue starting around 65,000, maybe Global Mapper would consider raising the max above 8,000.

    Thanks!
    Sara
  • SwoodySwoody Global Mapper User Posts: 97Trusted User
    Hi bmg_bob

    Yay! That is wonderful news - thank you!!!

    THANK YOOOOOU!
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,690
    bmg_bob said:
    I will also be adding an option to the KML/KMZ Export Options that will enable or disable the feature splitting function, but is not implemented yet.
    The option to enable or disable feature splitting was added to Global Mapper. This change is available in Global Mapper 18.1 daily builds dated Mar 15, 2017 or later.  Simply download the appropriate installer and run it to install the latest build.

    Cheers,
    Bob
  • SwoodySwoody Global Mapper User Posts: 97Trusted User
    Thanks again bmg_bob, I really appreciate that you folks are so responsive to issues like this.  
Sign In or Register to comment.