how to open .gms from cmd?

forticellaforticella Posts: 6
edited January 2016 in User Scripts
hello, i am really need help

i am trying to open a .gms file from cmd, i am successfully open another type of file from cmd but not .gms

here´s what i´ve typed on cmd "C:\Program Files\GlobalMapper16_64bit\global_mapper.exe" "C:\Users\TEMP\Desktop\script\script1.gms"

i try to open script1.gms manually from GM16 and it works perfectly.
script1.gms contains some load file and buffer creation script

is there anything missing from my command line? is there anything that i can do about it? please help me
Tagged:

Best Answer

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,702
    Answer ✓
    First, make sure you have the latest version of Global Mapper 16.

    Your command line looks correct.  What happens when you run this command?  Do you get an error message of some kind?

Answers

  • hello bob, i am currently use GM16.1, is that the problem? is this version isn´t compatible?

    should i put another command or anything to make my script1.gms works from  cmd?
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 1,702
    The command you used should work in GM 16.  What happened when you ran the command.  Did you get an error message?  When you run a script from the command line, you will not see the Global Mapper window appear.  Global Mapper will run the script without a window.  Have you tried using the SET_LOG_FILE command to create a file that contains all of the output messages?
  • JaneHJaneH Posts: 3
    Hi there, i cannot seem to run my .gms from command prompt either. It runs successfully if I manually open GM and run it in the app.

    in cmd my command is 

    C:\Users\amss>"C:\Program Files\GlobalMapper19_64bit\global_mapper.exe" "C:\Users\amss\Desktop\BatchClipLazToXYZ_noLog.gms"

    After a couple of seconds I get an error window that says "Global Mapper 19 has stopped working" and the only button available is "Close Program". No output is created at all.

    I have tried a .gms with log messages and have also removed those log message to see if that made any difference.

    The script is readng from a networked computer mapped drive and writing to a local folder.

    Please help!

    Thanks
    Jane
Sign In or Register to comment.